MarketPress update problems.

I have downloaded and followed all the instructions to update to the latest version of MarketPress. Why am I still getting messages that I have 2.8.1 installed and need to update. When I visit my plugin page it says that I have 2.8.4 installed.