MarketPress/GridMarket-Image Compression Software

After reading this very interesting link through wpmudev on reducing images for your website to improve page load, I decided to install Caesium software and give it a try.

I successfully reduced the size of my images by a staggering 85% + after setting the quality output at 50%.

Since I do use a lot of product images on my site, I felt that it would greatly improve my seo possibilities by compressing the overall size of these image files. (over 400 images in just two months I think!)

Although my website is only a few months old I had two monthly image files to compress and I was able to do this very easily, following Joe Foley's instructions using cPanel.

Unfortunately, only the first month worked properly and the second month would not show up in their respective featured image links etc.

I did try this procedure twice and got the same results but can't work out why the second months file would not work. I did have one mp3 within the second file and I removed this from the file before compressing it, as advised, and then I inserted it back again after compression of the image file.

I am wondering if in some way the structure could have been altered, resulting in the results for file # 2 mentioned above!

If anyone has any experience with this type of issue or can provide a possible solution to the above then it I would be much appreciated.

Kind Regards

James

  • Vaughan

    Hi James,

    It could be that when you unzipped, it created an extra folder. check in your uploads/xx folders that there isn't an extra subfolder

    uploads/xx/xx for example.

    You might also find one of the following useful. https://premium.wpmudev.org/blog/10-best-image-optimization-plugins-to-speed-up-your-wordpress-site/

    Can you paste a link to one of the pages where the images are broken & not displaying properly.

    Thanks

  • James

    Hi Jack,

    Thanks for your support for this issue!

    I have only two files in there to change for 07 and 08 respectively, which will be the compressed versions I am about to change back again. I set the image compression at 65% quality, although I could have gone much lower than this I think!

    I have installed smushit plugin as an alternative but I am reluctant to use it, as it would not be able to achieve the compression results as Caesium and there are a few restrictions with it.

    I will also enable the support access for you to navigate as you need to!

    Thanks again Jack for looking into this for me.

    Regards

    James

  • James

    Hi Jack,

    I have an immediate security issue on my site after updating 3 plugins on my site.

    I am unable to access my site or navigate and getting the following notice:

    "Briefly unavailable for scheduled maintenance. Check back in a minute."

    This is not something I have encountered before and I am unable to request support assistance through WPMUDev Dashboard.

    Can you tell me what this is as I am hoping its not some kind of hacking scam!

    Can you please get back to me ASAP and put my mind at rest!

    Thanks

    James

  • James

    Hi Jack,

    Just to let you know my site did come back online but gave me a bit of a scare as I had not encountered this notice before. I am assuming it was a WP update or something like that!

    Sorry to have contacted on this thread for this but couldn't access support through normal channels,

    BTW, I had to put my original image files back again, as I needed to work on my site. Please let me know if you wish to continue testing this issue as I have been unable to rectify the broken image links as yet.

    Can you tell me if Caesium has any problem compressing 3d images, that you may be aware of.

    I tried compressing a few images individually and inserting straight into my product page as featured image.

    I was able to do a 2d image successfully but the two 3d images had black kind of superimposed where it should be a transparent background, although the image itself looked fine. It was more like a shadow effect of the image itself,

    I have attached a couple of images to give you an idea of what I mean.

    Regards

    James

  • Jack Kitterhing

    Hi there @James,

    Hope you're well today and thanks for your patience on this.

    Glad to hear the sites back online! The issue you experienced was when WordPress does a update it places your site in maintenance mode, this is then removed once the update is complete.

    Sometimes the site can get stuck in maintenance mode which is what happened here, to resolve that, use FTP or your cPanel > file manager and delete the .maintenance folder :slight_smile:

    Regarding the backgrounds missing on the 3D images, Caesium as far as I'm aware doesn't have any issues with 3D images, though as it's image compression software if the image was a transparent .png, it's possible it actually removed the background when compressing.

    If possible could you add the broken images back, and copy the link for each image from the front-end of the site and post them here please? :slight_smile:

    Thanks!

    Kind Regards
    Jack.

  • James

    Hi Jack,

    Thanks for your reply and your comments regarding WP maintenance, I will keep that in mind.

    Regards the images, I will add them back again as requested but just wanted to confirm the link for each image. Do you mean the link that appears in the media library for each image like the three I include below?

    http://hypnosismultimedia.com/wp-content/uploads/2014/09/Stop-Worrying-CD_800x550.png
    http://hypnosismultimedia.com/wp-content/uploads/2014/09/Stop-Smoking-Today-CD-Blank-Disk_800x550.png
    http://hypnosismultimedia.com/wp-content/uploads/2014/09/Prosperity-Consciousness-CD_800x550.png

    If so, then I believe there are around 120 so far, can you let me know and will get them across to you straight away!

    Regards

    James

  • Jack Kitterhing

    Hi there @James,

    Hope you're well today and thanks for the additional information, I meant the broken front-end links on copy image location :slight_smile:

    I've just checked and one of them is

    http://hypnosismultimedia.com/wp-content/uploads/2014/08/Stop-Worrying-Script_778x526-300x202.png

    Can you check if that actually exists using FTP or your cPanel file manager, you'd need to navigate to wp-content/uploads/2014/08

    As the file link looks correct, but visiting it returns a page not found error.

    Thank you!

    Kind Regards
    Jack.

  • James

    Hi Jack,

    Thanks for the update and your comments regarding the broken link.

    I have checked through my cPanel and it looks like the images are showing up fine.

    I have renamed the original files-07-original and 08-original respectively and the compressed files showing now as 07 and 08 so that they take priority as shown in the attachments.

    I took a snap of the image url you have discussed and it does say "not found" but goes to web site.

    Can you advise further please?

    Thanks

    James

  • James

    Hi Jack,

    Hope all is well and thanks again for your recent comments. Have you had a chance to review my last post as I need to change the image folders back again, so I can work on my site.

    I am a little concerned about this issue as I will be a heavy user of images on the site and each product page will consist of a minimum of three images for each product.

    This really increases my media file sizes and will have quite an impact on loading the site and ultimately could affect my seo rankings etc.

    I see no reason why caesium should not be working properly as when I go through the compression procedure, all appears to go well, just as it should.

    All I need to do is rename the folders to reflect priority for the new compressed images but as you can see, I just get these broken links!

    I guess I can overcome the transparent issue by using a white background but the broken links remain the primary concern.

    When I am finished working on my site today I will change the image files back again but do let me know if you need this done beforehand.

    I will also grant support access again as it has most likely expired. Also Jack, if you would like to have a look in cPanel then please let me know, as you may get a clearer idea on the image files from there!

    Regards

    James

  • Jack Kitterhing

    Hi there @James,

    Hope you're well today, really appreciate your patience on this, this certainly should be working without any issues.

    Could you send me the following please to debug this? :slight_smile:

    - In the subject field add "Attn: Jack Kitterhing"
    - Link back to this thread
    - Include admin/network access
    - Include FTP
    - Include cPanel
    - Include any relevant URLS for your site

    On the contact form, select "I have a different question", this ensures it comes through and gets assigned to me.

    https://premium.wpmudev.org/contact/

    Thank you!

    Kind Regards
    Jack.

  • Jack Kitterhing

    Hi there James,

    Hope you're well today and thanks for sending through the details.

    After extensive testing it seems that compressing the images following those instructions actually breaks the media links, resulting in 404's, which is why the image isn't found.

    In this case, I'd recommend using specific WordPress software, such as WP Smush.it https://wordpress.org/plugins/wp-smushit/ :slight_smile:

    For your other issues, that you've discussed with Ash in your other thread, your custom menu links in the latest version would now be added in wp-admin > appearance > menus > links. :slight_smile:

    I see you have a few different menus in place, was it uber menu 2 menu that you was having issues with?

    We're here to help. :slight_smile:

    Thanks!

    Kind Regards
    Jack.

  • James

    Hi Jack,

    I am still having a couple of issues after I had a wordpress update the other week and unable as yet to resolve it. It really messed up my navigation menu badly, although I was able to repair some of the site.

    What still remains a bit of a mystery is that within my menu admin area, the "Custom" field for adding new headings to my menu has gone missing!

    As a result, I had to add a new page as a 1st level heading "Hypnosis CDs" in order to repair the sub item categories that were all over the place.

    I have attached a screen shot of the left hand side of the menu's admin area where it was previously located and is now missing. I have searched but unable to locate it in other areas and was hoping you may be able to assist with this issue.

    In addition, the last 1st level in the navigation menu "Products" has somehow repeated itself within the main menu sub items and I am unable to delete them from the menu admin area. They have duplicated themselves several times as more sub items and this can be seen if you hover over the "Products" tab on the navigation bar on the site or can be viewed within the mune admin page.

    Just why this has happened is a complete mystery to me but I am sure that it was after I updated to the newest version of wordpress recently.

    I have also included a screen shot of the navigation bar which shows the last item "Products".

    I have now spent well over a week trying to resolve this but at a loss to get to the bottom of these problems, which have corrupted the site.

    I am unaware of any other issues that may have been effected by this recent update, but for now I would appreciate your help with the above.

    Thanks in advance for your attention to the above request.

    Regards

    James

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.