Markets press widget issue STILL

When trying to a a link back to our store from the widget, When i click save the widget changes the the text to Continue Shopping
I was promised this was fixed in version 2.5.5 so i joined downloaded 2.5.8 and same issue.

also is there a way to add SKUs to the export feature I REALLY need that.

  • 3SixtyEvolve

    Hi @wclune

    Thank you for being a member and for posting to the forum.

    I'm sorry that you're facing problems with the MarketPress Plugin. I didn't find any previous posts of yours mentioning this error, so I wasn't able to figure out exactly what the error you're getting. If you can provide a link to your site I can check it.

    Also, please confirm whether you have other plugins activated and what theme you're using.

    I look forward to getting this sorted out for you.

    Have a good day!

    Gina

  • wclune

    My frustration is really mounting
    "Bracket" a target="_blank" href="http://ldrs31.org/store/products/" "bracket" Contiunue Shopping "anchor"

    Becomes this

    "bracket" a href=\"http://ldrs31.org/store/products/\" "bracket" Contiunue Shopping "anchor"

    also can someone tell me yeah or neah on the export feature giving me product SKU's

    this system you folks have hear may work great for full time developers but frankly SUCKS for us mortals
    Sorry way to many hours spent on my part for this shopping cart

  • 3SixtyEvolve

    Hi @wclune

    Thank you for expressing your views. Feedback is always good and helps us to improve. So we do appreciate you telling us how you've experienced things.

    I had a look at your site - the links that you provided and I see what is happening. Is it possible to provide me with access to your WP Admin? I would like to have a look at your settings there. You can send the details to gina at incsub dot com.

    Also, with regards to SKU export capabilities. I asked the Developer about this and he said that csv exports don't include cart details at the moment; it's meant for accounting purposes only and there isn't a way to include cart items in a single spreadsheet line.

    Look forward to your feedback.

    Have a good day.

    Gina

  • 3SixtyEvolve

    Hi @wclune

    I was simply requesting access to your WordPress Admin Panel to see if I can get to the bottom of the problem.

    I have gone through all your previous email correspondence with the rest of our team and from what I understand you have upgraded to the latest version of MarketPress 2.5.8. How did you upgrade?

    If you upgraded via the WordPress Admin Panel then I would like to suggest that you access the plugin folder via your FTP Client and delete it from there and then re-install it via FTP. So you would go to the root folder of your hosting and then to wp-contents/plugins where you will find the 'marketpress' plugin folder.

    After re-installing the Plugin, please check if the error with the link in the Shopping Cart Widget persist.

    I look forward to your feedback.

    Gina

  • wclune

    I understand why you asked. I know other would become upset if i did that.

    as for how i updated. it was a market press lite install from the WP admin panel. after joining i downloaded the .zip file and did the install via admin panel upload feature. de-activated the lite version and activated the pro. my concern with deleting the files and uploading via FTP is.
    1 the is an abondance of sales in that store if i loose that data we are screwed I will have no way of even ordering the shirts for the events let alone delivering them.
    2 not sure i even can do that as we don't have root access to the server its housed on and FTP seems to have permission problems.

  • Timothy Bowers

    Hey there.

    Ya it should have been fixed, not sure why it isn't. I spoke with Aaron about this yesterday, he then made a release the fix the widget issue.

    Please upgrade to the latest. Thanks.

    1 the is an abondance of sales in that store if i loose that data we are screwed I will have no way of even ordering the shirts for the events let alone delivering them.

    2 not sure i even can do that as we don't have root access to the server its housed on and FTP seems to have permission problems.

    Please ensure you have a constant and current backup. If your hosting HDs ever crash you will want them as well.

    Upgrading plugins should just be a case of deleting one and adding the other.

    You wouldn't need root access to your host?

    If you are getting permissions problems it would be worth speaking with your host about resolving that.

    Take care.

  • wclune

    All your efforts are appreciated!
    Yes 2.5.9 took care of the widget issue.

    Has Arron any Idea When/if a real "continue shopping" button might be added? It really is wonderful other than that.

    As for root access this is a funny situation, I think. Wordpress is installed using the user account given to us for access But WP runs as apache which seems to be in the group root. When we add things such as plugins using the WP admin pages they get installed not as our user account but as user "apache". I cant even SSH in and do a Chown as I don't have root access. so we don't have permissions to change anything using FTP or SSH. Once it is installed using WP Admin were stuck with it.

  • Timothy Bowers

    Has Arron any Idea When/if a real "continue shopping" button might be added? It really is wonderful other than that.

    When I spoke to him last about this (when we exchanged emails in March.. I think it was March) it wasn't something on the cards because it isn't requested that often and it is easy enough to add with the widget. Of course though, It is something relatively simple so if we can get enough people adding their support for this then I see no reason it wouldn't be added. :slight_smile:

    As for root access this is a funny situation, I think. Wordpress is installed using the user account given to us for access But WP runs as apache which seems to be in the group root. When we add things such as plugins using the WP admin pages they get installed not as our user account but as user "apache". I cant even SSH in and do a Chown as I don't have root access. so we don't have permissions to change anything using FTP or SSH. Once it is installed using WP Admin were stuck with it.

    Ouch, that is definitely a setup issue there, you should never need to chown and it should be assigned to your user/group.

    So will upgrades only work through WordPress then? The automatic update?

    I would look to getting the host resolve this, you see if you upgrade WordPress, a plugin or a theme sometimes something will happen like a drop in connection or a file doesn't unpack which can result in leaving your site in Maintenance mode.

    When this happens you need FTP/SSH access to remove a file so your website will function. If you don't then no one will be able to access the site until its done, they will receive a Maintenance message.

    Take care.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.