Maximum pages per unit

Hi,
is there a maximum creating pages per unit? I have a unit contains 28 lectures/pages. Creation and saving works fine till page 21. Create a page 22 also works.

After saving the work only 21 pages are shown. I cannot put one more page to the unit. Can you help me?

regards,
Michael

  • Kasia Swiderska
    • Support nomad

    Hello Michael,

    is there a maximum creating pages per unit?

    There is no limit, but limits on memory can cause this issue. Please try increasing values for:
    - max_input_vars
    - post_max_size
    - upload_max_filesize

    You might need to contact your hosting provider to do that for you.
    Let me know how it goes.

    kind regards,
    Kasia

  • Nithin
    • Support Wizard

    Hi Michael,

    Hope you are doing good today. :slight_smile:

    As mentioned above this is related to the memory limit, could you please check whether your WordPress website is making use of the increased memory limit. You can check that under WPMU DEV > Support > System Info. Where the PHP tab will show the php values you have set, and the WordPress tab will show WP_MEMORY_LIMIT, and WP_MAX_MEMORY_LIMIT.

    Please check whether these constants are same as your memory limit, if not try increasing this by defining these in your wp-config.php file located in your root directory.

    define( 'WP_MEMORY_LIMIT', '3000M' );
    define( 'WP_MAX_MEMORY_LIMIT', '3000M' );

    Please do note to add these before the line /* That's all, stop editing! Happy blogging. */.

    If you have already preformed this, could you please enable support access. So that we could give a look.

    I hope this helps. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

  • Kasia Swiderska
    • Support nomad

    Hello Michael,

    Does the memory is increased on your server and adding new page still doesn't work or increasing is not working?
    Can you try increasing values for those
    - max_input_vars
    - post_max_size
    - upload_max_filesize

    a little bit more?

    If increasing memory works but pages still cannot be add can you enable debug mode and try again?
    To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

    define('WP_DEBUG', true);

    In order to enable the error logging to a file on the server you need to add yet one more similar line:

    define( 'WP_DEBUG_LOG', true );

    In this case the errors will be saved to a debug.log log file inside the /wp-content/directory.

    Depending on whether you want your errors to be only logged or also displayed on the screen you should also have this line there, immediately after the line mentioned above:

    define( 'WP_DEBUG_DISPLAY', false );

    The wp-config.php is located in your WordPress root directory. It’s the same file where the database configuration settings are. You will have to access it by FTP or SFTP in order to edit it. I would need then to see contents of the debug.log file - so please paste it to the text file and attach to post.

    kind regards,
    Kasia

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.