Media grid not working in multisite

Hi
I have set up a multisite and currently have 3 sites - the main site is complete and I am starting to build landing pages on the other 2. The media library works fine in the main site, however, in the 2nd and 3rd site the media grid just sits and spins and will not let me upload any images - I get an error. If I switch to media list mode i can upload via the browsers builtin uploader and see the images. I can not place the images on my pages or add a logo to the headers because they are accessed via the media grid & upload. I have tried looking at my permissions and they seem to be set correctly.

I have also noticed an error message that appears at the bottom of the dashboard on the 2nd and 3rd sites. It says "An internal error or misconfiguration and was unable to complete your request. Please contact the server administrator, [no address given] and inform them of the time the error occurred, and anything you might have done that may have caused the error.
More information about this error may be available in the server error log." I have contacted my hosting provider about the error but they can't find any errors for those sites.

I am at a loss as to how to fix the issue and I can't go any further in building without resolving.

Please help!
Angie

  • Kasia Swiderska

    Hello Angie,

    Have you run conflict test to exclude that issue is caused by something installed in your system?
    Plugin/theme conflict test as described in getting support manual E. Plugin Conflict Test
    https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-2

    That error message suggest that internal server error 500 is showing on your site - one of the reason for this error to show is plugin/theme conflict.

    I googled more about grid view issues and I found this information https://wordpress.stackexchange.com/a/258141 - so this is also worth checking.

    Check also this solution: https://wordpress.org/support/topic/4-7-4-media-library-not-loading-in-grid-view/#post-9121663

    I quickly run a check on my fresh Multisite, but on subsites grid view works fine for subsites so it doesn't looks like bug in WordPress itself.

    kind regards,
    Kasia

  • Angie Schultz

    Hello Kasia,
    Thank you for your response! I have tried turning off plugins and switching the theme - neither of those solved the issue with the media grid or the Internal error message. The main site is using the same theme and plugins as the other 2 sites and is working perfectly - no server errors, no issues with viewing the media grid or uploading images and no issues adding images to pages and posts.

    I did try the "define( 'SCRIPT_DEBUG', true ); " addition that you sent a link for but it also did not fix the issue so I removed it. I did turn on the wp_debug in my wp_config and am getting a couple of messages which concern the theme - I have sent a message to the theme developer about them. See messages below.
    Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; TRX_Importer has a deprecated constructor in /data/50/5/30/79/5030894/user/6055732/htdocs/wp-content/themes/wine/admin/tools/importer/importer.php on line 4

    Notice: Undefined variable: avg_author in /data/50/5/30/79/5030894/user/6055732/htdocs/wp-content/themes/wine/templates/page-part-reviews-block.php on line 5

    I also looked into the other link that you sent about the force regenerate thumbnails plugin but that plugin has not been update in a year and has not been tested with the last 3 versions of WordPress so I did not try that one.

    I have looked at my wp_config and .htaccess files to make sure they are set up correctly - they match what is in my network setup and what I have found online while troubleshooting. I have also looked into the permissions on my folders and they are set correctly.

    There is a disconnect somewhere and I am not sure what to do next.
    Thanks,
    Angie

  • Kasia Swiderska

    Hello Angie,

    I also looked into the other link that you sent about the force regenerate thumbnails plugin but that plugin has not been update in a year and has not been tested with the last 3 versions of WordPress so I did not try that one.

    You don't need to use that particular plugin - there are others that do the same thing (regenerating thumbnails) like this one: https://wordpress.org/plugins/regenerate-thumbnails/

    If that will not help, would you mind allowing support access so we can have a closer look at this?
    To enable support access you can follow this guide here:
    https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-5

    kind regards,
    Kasia

  • Kasia Swiderska

    Hello Angie,

    I have taken look on your site and unfortunately there was nothing in browser error console that would suggest what is breaking grid view.
    When you run plugin conflict test - have you also disabled Network activated plugins or just one that are on subsites?

    I noticed that max_execution_time for your site is bit low: 30. And that error in Media Library is very often related to memory limits. So if you could try increasing that value maybe that will help?
    https://premium.wpmudev.org/blog/increase-memory-limit/
    Your current limits can be found in WPMU DEV -> Support -> System Info.

    I have contacted my hosting provider about the error but they can't find any errors for those sites.

    Another thing is to enable debug.log - because if there is error on upload, it should show in logs. I know that your hosting provider checked logs, but if they are not familiar with how Multisite works they might not realize that they need to look for errors for the main site installation, not specific subsites.

    To enable debug.log, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:
    define('WP_DEBUG', true);
    In order to enable the error logging to a file on the server you need to add yet one more similar line:

    define( 'WP_DEBUG_LOG', true );

    In this case the errors will be saved to a debug.log log file inside the /wp-content/directory.

    Depending on whether you want your errors to be only logged or also displayed on the screen you should also have this line there, immediately after the line mentioned above:

    define( 'WP_DEBUG_DISPLAY', false );

    The wp-config.php is located in your WordPress root directory. It’s the same file where the database configuration settings are. You will have to access it by FTP or SFTP in order to edit it.

    After you enable it, please try switching to grid look few times and try to upload images few times, so errors will generate.

    I would need then to see content of the debug.log file - so please upload it to service like a Dropbox and paste link here.

    kind regards
    Kasia

  • Angie Schultz

    Hi Kaisa,
    Thank you for the quick response!

    All of the plugins except the Regenerate Thumbnails which I recently uploaded are activated across the network so I deactivated the plugins network wide when I did the test.

    I followed the instructions in the link you sent for increasing the max_execution_time. The php.ini version did had no affect and did not change the settings. The .htaccess version caused a 500 Internal server error and this message was in the error log "[Tue Feb 20 10:01:45 2018][alert] [client 108.248.101.32] /data/50/5/30/79/5030894/user/6055732/htdocs/.htaccess: Invalid command 'php_value', perhaps misspelled or defined by a module not included in the server configuration"
    The wp_config version increased the wp_memory limit but had no affect on the max_execution_time or the media grid issue.

    The wp_debug has been on since Friday. I have uploaded it to Dropbox - I am not sure what the messages mean that are in there - I had noticed the message before and sent it to my theme developer and received no help from them. Below is the link to the debug log.

    https://www.dropbox.com/s/7l9ke39ftacchj6/debug.log?dl=0

    If needed I can give you access to the ftp.

    Any help you can off would be great! My client is getting very impatient to get there store pages up (there are 15 of them) and I have been trying to figure this out for a couple of weeks now.

    Thank you,
    Angie

  • Kasia Swiderska

    Hello Angie,

    Can you ask hosting provider about increasing max_timeout limit? If methods from blog post were not working it means that only provider can change that settings.

    I tried few other things, but without success - I checked error logs and there are Fatal Errors pointing to one of the plugins

    [15-Jan-2018 22:01:08 UTC] PHP Fatal error:  Uncaught Error: Call to undefined function submit_button() in wp-admin/includes/file.php:1767
    Stack trace:
    #0 /wp-content/plugins/additional-tags/includes/plugin.files.php(398): request_filesystem_credentials('http://www.wine...', 'ftpext', false, false, Array)

    but it doesn't seem related if Grid is not working with this plugin deactivated.

    I would like to take more closer look in this case - could you please send in the following via our secure contact form https://premium.wpmudev.org/contact/#i-have-a-different-question :

    - Mark to my attention, the subject line should contain only: ATTN: Kasia Swiderska
    - Do not include anything else in the subject line, doing so may delay our response due to how email filtering works.
    - Link back to this thread
    - Include WordPress network admin access details (login address, username & password)
    - Include FTP log-in details (hostname, username & password)
    - Include any relevant URLs for your site

    IMPORTANT: Please make sure you select "I have a different question" for your topic, so it doesn't go back to the forums - this and the subject line ensure that it gets assigned to me.

    Please confirm here that you send those credentials

    kind regards,
    Kasia

  • Kasia Swiderska

    Hello Angie,

    Debug.log was still not showing anything new, but I found there is server error_log file and it shows this error quite often

    [Sun Feb 25 00:27:48 2018][error] [client 217.147.XX.XX] Request exceeded the limit of 10 internal redirects due to probable configuration error. Use 'LimitInternalRecursion' to increase the limit if necessary. Use 'LogLevel debug' to get a backtrace.

    Can you show this to hosting provider and ask if they can fix it? And also if they can try to increase "max_execution_time" to maybe 180 (I tried to do that on my own now, with php.ini file but it's not working)?

    Please also tell me if you have a backup of the site, because I want to try one thing more, but it will require disabling that theme on all sites.

    kind regards,
    Kasia

  • Angie Schultz

    Hi Kasia,

    Prior to beginning this whole website project build out, I specifically asked the web host provider if their hosting package and server would support a WordPress mulitsite installation, to which they replied "Yes, no problem". Yesterday, after being locked out of the site, the provider tells me that our database has exceeded the limit and in fact would NOT support the multisite installation! Unbelievable!

    Anyway, I think that I have figured out why things aren't working and I am getting errors. We are going to have to move the site now to a provider that can support the multisite installation. Uggg.

    I am so grateful to you and your team for your tireless effort and time that you have spent trying to solve this issue! You are amazing! If I have issues in the future I will be sure to contact you and I will let others know to join wpmudev!

    Thank you again!
    Angie

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.