Media library is not showing when WP Offload S3 and Smush Pro work together.

I am having an issue with Smush Pro and WP Offload S3. The media window does not load any images. If you log onto my site and activate smush pro and go to media you will see the issue. Please help.

  • Dimitris

    Hello there mat,

    hope you're doing good today! :slight_smile:

    I can see that you don't use the latest version of the WP Offload Media plugin, could you please update it to version 2.0 and let us know if that made any difference?
    https://deliciousbrains.com/wp-offload-media/doc/changelog/

    If update doesn't make any difference, please try to enable WP_DEBUG in case we can get any further information about the error itself. Please access your server via FTP, edit wp-config.php file, find a line like
    define('WP_DEBUG', false);and replace it with the following (if the above line doesn’t exist, simply insert next snippet just above the /* That's all, stop editing! Happy blogging. */ comment)

    // Enable WP_DEBUG mode
    define('WP_DEBUG', true);
    // Enable Debug logging to the /wp-content/debug.log file
    define('WP_DEBUG_LOG', true);
    @ini_set( 'log_errors', 1 );
    // Disable display of errors and warnings
    define('WP_DEBUG_DISPLAY', false);
    @ini_set('display_errors', 0);

    Then go ahead and try to replicate the error by installing and activating Smush Pro, then visiting the Media Library page.
    By doing so, a /wp-content/debug.log file should be created. Simply download it, rename it to debug.txt and attach it here in your next reply. If size of text file exceeds the 5MB limit of our blog, please use a service like Dropbox and post the shareable link instead.
    Ref: https://premium.wpmudev.org/blog/debugging-wordpress-how-to-use-wp_debug/

    Looking forward for your results!

    Thank you,
    Dimitris

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.