Media won't backup in snapshot

Media Files won't backup with a regular Snapshot or Managed Backup. The backup shows a blank page with a 500 error in the developer console.

  • Kris Tomczyk

    Hi Alexander James Media Limited

    Hope you are doing good today.

    I made some test on your site related toyour php.ini file:
    - I increase memory_limit to 1024
    - I added "file_uploads = On"
    - I increase max_execution_time to 600

    But this gave same results. Snapshot stucks at media folder.

    After that I restored all your settings.

    In debug.log on you FTP during this process I saw this error:
    PHP Notice: Undefined index: interval-offset in /******/wp-content/plugins/snapshot/views/snapshots/snapshot.php on line 908

    I inform our DEVs to take a closer look on this issue. Since team deals with more advanced threads it may take them longer to reply.

    In meantime would you please run a conflict test? Please deactivate all plugins except Snapshot and check if the problem gone. If so, then enable all plugins one by one and find which one is having conflict. If there is no positive result, switch to default WordPress theme like 2017 and see if it works.

    Kind Regards,
    Kris

  • Lindeni Mahlalela

    Hello Alexander James Media Limited

    I hope you are doing great today. I am sorry for the issues you are having with our Snapshot plugin. Thank you for your patience as we were looking into this issue.

    I have inspected your setup and found that in the /wp-content/uploads there was a folder named 'backupbuddy_backups' which seems to contain a backup from another Backup plugin. This backup folder contains a huge zip file of about 1.5Gb. I have specified in the Snapshot settings page to exclude this folder in the 'Global Files Exclusions".

    After that I ran a Snapshot backup that includes everything except that specific folder. After this Snapshot worked very well as I was able to created two Snapshots without issues:

    So this means Snapshot was failing in the 'media' step because of the huge 'backupbuddy_backups' folder, excluding it resulted in Snapshot working as it should.

    I hope this helps. Please let us know if you need any further assistance with regards to this and we will always be happy to help in anyway possible.

    Have a nice day.
    Mahlamusa