Member registration and member login needs to be solved

Valued Support Team,

meanwhile Jose fixed the complex severe issue we experienced. now he suggested to request support from you guys to help fixing this issues once again in order to get m2pro functioning properly.

Current situation: registered member can login but that's it.... means, when continuing to view other sites within our application, user isn't really logged in. In short member login/logout as well redirect to any pages is blocked by m2pro. So, it needs to be fixed.

Also:
New user registration failure... e.g. choosing membership level in order to register does not work anymore. So, it needs to be fixed too.

Hope, we'll be supported from you shortly.
Cheers
Prinz

Support access is granted

  • Sajid
    • DEV MAN’s Sidekick

    Hi @Prinz

    Hope you are doing good today :slight_smile:

    I am glad to know Jose fixed your server issue. I have tried to register on your website from membership page and also using register page. But both pages are protected with membership 2 so I could not register a user for testing and neither could login.

    These pages must be public so new user can register. Please remove the membership access on these pages and let me know so I would be able to register a test user. Keep the support access open.

    Look forward towards your response :slight_smile:

    Cheers, Sajid

  • Klaus
    • The Crimson Coder

    Hello Sajid,

    thanks for prompt reply. Checked once again as recommended pages... not a single page on main domain is protected (and never was), see attached screenshot.

    Attached other screenshot as well, e.g. membership of ALL registered has changed now but there were before and should be at membership level of BotBO Recruiter.

    Perhaps this information is helpful: current m2pro issue turned up first (until than it was working properly) at the time the major problem occurred but as you know Jose solved that.

    Looking forward to hear from you.
    Cheers
    Prinz

  • Sajid
    • DEV MAN’s Sidekick

    Hi @Prinz

    Hope you are doing good today :slight_smile:

    I am sorry about the delay on this ticket. Its not the registration page that is protected may be a parent page or something else. I am being taken to protected page when I try to register an account on guest membership registration page , as seen in screenshot. After clicking on next blue button on this page to join, sigup membership page still brings me on exact page so its a loop.

    The pages in your screenshot one are BuddyPress registration pages. These pages (registration) must be different then those you selected for membership 2 signup to avoid conflicts.

    I have sent offline message to Jose to get more information about this issue to handle it. I will post back here once I heard from him.

    Take care and have a nice day :slight_smile:

    Cheers, Sajid

  • Sajid
    • DEV MAN’s Sidekick

    Hi @Prinz

    Hope you are doing good today :slight_smile:

    First of all, I have a good news for you :slight_smile: The signup issue issue is fixed. There were register page conflict with BuddyPress.

    Okay no regarding the actual issues you posted in your original message here.

    Current situation: registered member can login but that's it.... means, when continuing to view other sites within our application, user isn't really logged in. In short member login/logout as well redirect to any pages is blocked by m2pro. So, it needs to be fixed.

    I have tried to logged in with newly created test user account on your website and it was successful. Then with that login session I subscribed for your one day membership and it went successful, see screenshots.

    Also:
    New user registration failure... e.g. choosing membership level in order to register does not work anymore. So, it needs to be fixed too.

    Yes, this seems to be an issue. Its got stuck at checkout page and did not auto login the newly registered user that M2 normally does. Upon further troubleshooting and investigation I found the culprit. Its New User Approve plugin that disables user's auto login and in result breaking the singup process. I registered a new user and the registration went smooth this time including checkout with stripe.

    I have activated that plugin again on your site after testing. But if you want to approve your members first then I am afriad you have to disable membership to signup and register the users first with BuddyPress. When they are approved and verified then send them to memberships page to checkout.

    Hope that helps :slight_smile: or feel free to post a reply if you need further assistance.

    Cheers, Sajid

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.