Members can not access protected content + auto log out issues

Members are reporting 2 issues.

1. After login they are still seeing the protected content message
2. Members are also reporting that they are being auto-logged out of the site after visiting another page on the site that is NOT protected.

** I have enabled support access via dashboard.

  • Adam Czajczyk
    • Support Gorilla

    Hello Jason,

    I hope you're well today and thank you for your question!

    I've registered on you site and signed up for free membership and I was able to see protected pages. I wasn't also logged-out after browsing other (non-protected) pages.

    That said, does this issue occur only for certain members or for all of them? Also, does this members by any chance visit your site using Internet Explorer 11 (or earlier)?

    Please advise!

    Best regards,
    Adam

  • Jason
    • Site Builder, Child of Zeus

    Message from member with issue:

    " I have switched to internet explorer 11 and still cant access your site, in google chrome I can login and get to some information, but till get kicked out when I try to view players hitting value, nba dvp matchups, nba bargain tool and nba games to target. Any help you can give me is appreciated. Is there a better browser to go into that would solve this?"

  • Adam Czajczyk
    • Support Gorilla

    Hello Jason,

    Thank you for your replay.

    I asked specifically about IE 11 (and older) because there are indeed some issues related to default security settings of that browser and the way Microsoft made it handle those issues. Unfortunately, the code is "closed' and, furthermore, it's no longer supported and this makes it extremely difficult to find solution. Our developers however are still working on this.

    I've run some more testes using Edge under Win 10 and it seems that the same issue occurs here. Since Microsoft 10, and as a result Microsoft Edge, is recently being massively installed on both new and older machines (due to the MS "free update" policy) this makes the issue urgent.

    That said, I'm immediately forwarding this to developers and hopefully they'll act as quickly as possible on this.

    As for "getting kicked out" in Chrome. I have also tested this on my test setup but wasn't able to replicate the issue. Therefore I'd love to take a closer look at your setup if you don't mind. In order to let me do this, could you please grant me a support access using our WPMU DEV Dashboard plugin?

    To do this, please follow this guide:

    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Best regards,
    Adam

  • Jude
    • DEV MAN

    Howdy Jason

    Sorry this took much longer than expected, but the bug raised in this ticket is fixed.

    https://www.dropbox.com/s/0e6lafcejpb2pyj/membership2-1.0.28-Beta-2.zip?dl=0

    Also a note of caution, this is a beta version, while unlikely it may not be 100% stable and may evolve and change a bit before the final release. Its more of a temporary workaround as opposed to a long term solution.

    To install the beta, simply deactivate and delete your current version then upload the attached zip folder via: Plugins > Add New > Upload. Will be happy to install it for you if needed

    Cheers
    Jude

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.