Members Directory plugin disables widgets

Hi, I'm building a Wordpress (regular, not multi-site) site with the following of your plugins: Membership Premium, Events +, E-Newsletter, Fundraising, Google Maps, Members Directory.

I have two questions:
1. The Members Directory plugin disables widgets. When I use the above combination of plugins, I cannot open any drop down (e.g. help & screen options drop downs at the top of each page), nor move any widget into the sidebar sections. Disabling Members Directory fixes this. Is there a solution to this?
2. Membership Premium interaction with Events +. I would like to have event information public but allow only signed-in members to RSVP for events. Is there a way of doing this?

Thanks in advance for your help!

  • Arun Basil Lal
    • New Recruit

    Hello NIREC,

    Welcome to the Forum!

    Let me try to help you here:

    1. The Members Directory plugin disables widgets. When I use the above combination of plugins, I cannot open any drop down (e.g. help & screen options drop downs at the top of each page), nor move any widget into the sidebar sections. Disabling Members Directory fixes this. Is there a solution to this?

    Should be a javascript conflict. First, try it in a different browser, that should be it. If that doesn't fix it, as an immediate solution you could disable the plugin, set all the widgets and then enable the plugin again. Let me know if this was a browser issue, if not, I will ask the developer to take a look into this.

    2. Membership Premium interaction with Events +. I would like to have event information public but allow only signed-in members to RSVP for events. Is there a way of doing this?

    Actually, the Events+ plugin has a Membership module to integrate with the Membership plugin. With the module active, you can have events that are paid for non-members and free for members. You could set a pretty high price and leave a note that says, all members get it for free. It could be one of the ways to push sign-ups :slight_smile:

    Check on the Settings page of Events + plugin.

    Hope these helps :slight_smile:

  • NIREC
    • WPMU DEV Initiate

    Thanks Arun.

    I'll use the workaround that you suggest for part 2.

    For the first part, changing browsers doesn't work; I tried Firefox, Chromer & IE with the same result in each.

    In addition, when I create an event, add dates, times, Google map and capacity limit, I cannot save it as a draft. It just hangs. The Preview button won't work either. This does seem like a javascript issue, and it would be really helpful if you could have a developer take a look at it. I've disabled all other plugins aside from Askimet & Cufon for the moment. Also, I have tried numerous themes, including the default Wordpress one and that seems to have no impact.

    Thanks for your help.

  • Arun Basil Lal
    • New Recruit

    That Cufon plugin might be the culprit, it uses javascript to modify fonts, try disabling that for testing sake.

    In addition, when I create an event, add dates, times, Google map and capacity limit, I cannot save it as a draft. It just hangs. The Preview button won't work either.

    What happens when you click save as draft? Does the page go blank? Still can you publish the event?

  • NIREC
    • WPMU DEV Initiate

    Thanks Arun.

    It wasn't the Cufon plugin.

    The Events + is now working fine; I cleared out the cache, restarted and created a new event, and it's great now. For reference, when I hit 'save draft', it looked like it was saving (the saving symbol was there), but it hung at that point. If I right clicked on the 'preview', I could indeed see the preview in another tab, but the button wasn't working directly. Hope this makes sense!

    The Member Directory issue still remains unfortunately.

  • Arun Basil Lal
    • New Recruit

    So now the big issue is that when the Members Directory is activated, Dragging widgets and opening "Screen Options" isn't working, right?

    I went ahead and tested it out and it was working fine for me. Hmm..

    Let me notify the developer and see if he has any suggestions for that one. :slight_smile:

  • S H Mohanjith
    • Developer

    I cannot reproduce the issue.

    It sounds like a javascript issue, however members directory plugin doesn't have a single line of javascript.

    Can you please try to disable all plugins except the Members Directory plugin and see whether it helps? If so can you please enable one plugin at a time until the issue appears?

  • NIREC
    • WPMU DEV Initiate

    The issue occurs even when the Member Directory is the only plugin activated. It occurs regardless of the theme that I'm using, even the Wordpress default one.

    Is there any way that I can show a list of all site members to other members without using this plugin?

    Thanks for your help.

  • aecnu
    • WP Unicorn

    Greetings Folks,

    Perhaps everyone is having such trouble resolving this issue and the developer Moha cannot replicate the issue simply because of the fact that NIREC is trying to use this MultiSite only plugin on a Solo WordPress install.

    It is not supposed to work on a Solo WordPress install.

    Marking this ticket as resolved since the plugin in question has been miss-applied and therefore the resulting issues.

    Thank you for being a WPMU Dev Member!

    Cheers, Joe

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.