Membership 2 automatic updates switching off plugin

Hi we have a reoccurring problem when an automatic update happens on this website, where Membership2 is switching off (the error message in the plugins area is that it doesn't exist) and from looking at the WPMU dashboard on the site, it still appears to be there.
I noticed a support thread on this already which suggests deleting and reinstalling the plugin, which is what I have been able to do, sometimes it's possible to reactivate it but it's the basic level of the plugin so some of the add-ons we need for the site (additional profile fields) won't work. In order to fix it, I have to delete the plugin and try and delete the files via file manager and then reinstall via the hub. none of which is ideal as we only realise there is a problem when our client's customers report not being able to use the website. This has happened about 4 times in the last month.

Is there are a way to make it so that website updates don't cause this plugin to switch off please?

Best Wishes

Jess

  • Sohag Ronjon Dey

    Hi Jessica,

    Thanks for contacting us and I hope you are having a beautiful day! :slight_smile:

    You need to keep WPMU DEV Dashboard plugin active when update happens and when you re-install the plugin. That confirms that you are active member, eligible for Pro version; otherwise plugin is updated directly from wp.org repository and turns back to "lite" (free version). Also, if it already turned to free version and you are trying to re-install using package that you have downloaded from our site (which is pro of course), it won't activate Pro features if WPMU DEV Dashboard is disabled at the time of that re-install. So make sure the WPMU DEV Dahboard plugin is active when you update wordpress and re-install the plugin.

    Hope this helps.

    Please let us know if you need any further help.

    Cheers,
    Sohag

  • Sohag Ronjon Dey

    Hi Jessica,

    Thanks for the prompt reply! :slight_smile:

    So far the issue has not occurred when the The WPMUdev plugin has remained activated. As it is not working at your end we would recommend you to enable debug mode in your site which will log the errors in a file in your sites backend and will help us to have a better idea.

    To enable debug mode, open your wp-config.php file located in your site's root directory, and look for

    define( 'WP_DEBUG', false );

    replace it with:

    define( 'WP_DEBUG', true );
    define( 'WP_DEBUG_LOG', true );
    define( 'WP_DEBUG_DISPLAY', false );

    This will log the errors and prevent to show the errors on the front end.

    Once done, wait until the issue occurs again and then find the debug.log at /wp-content folder and send us the debug log and if possible also send us the server logs. Maybe this will help identify the issue.

    I will look forward to hearing from you.

    Cheers,
    Sohag

  • Sohag Ronjon Dey

    Hey Jessica,

    Thanks for the reply and I hope you are doing well. :slight_smile:

    As this is an ongoing problem, it seems to be an IP related issue, could you please contact your hosting provider to make sure that our URL isn't being blocked somehow?

    https://premium.wpmudev.org/api/

    You can also provide us your IP (keep in mind that this is a public forum so if you don't want to share it here just notify us to provide another way) and test with our system administrators that you aren't being blocked from our behalf somehow.

    Cheers,
    Sohag

  • Predrag Dubajic

    Hi Jessica,

    You can send us your IP address by using our contact form https://premium.wpmudev.org/contact/#i-have-a-different-question and the template below:

    Subject: "Attn: Predrag Dubajic"
    - IP Address
    - Link back to this thread for reference
    - Any other relevant urls

    Also, is it possible for you to setup a staging site where we could perform some additional tests without affecting your live installation?

    Best regards,
    Predrag

  • Sohag Ronjon Dey

    Hi Jessica,

    Thanks for the email and I hope you are doing well. :slight_smile:

    I have checked your server ip and found it is not blocked by our site. Sorry to know that you are facing some inconvenience while setting up staging site. Please check the following and see if these can help

    https://premium.wpmudev.org/blog/set-up-staging-site-cheap-shared-hosting/
    https://www.a2hosting.com/kb/a2-hosting-products/windows-hosting/website-staging-with-plesk

    As you are facing issue with setting up staging site could you please send us your details through our contact form so that we can try to investigate the issue further, for avoiding any unexpected break in the site or any loss of data or file please keep a full backup of your site's file and database.

    Please use this form as you did earlier

    https://premium.wpmudev.org/contact/#i-have-a-different-question

    Subject: "Attn: Sohag"
    -WordPress admin username
    -WordPress admin password
    -login url
    -ftp credentials (host/username/password)
    -link back to this thread for reference
    -any other relevant urls

    Select "I have a different question" for your topic - this and the subject line ensure that it gets assigned to me

    Please DO NOT post the credentials here as this is a public forum, also would you mind me doing some basic troubleshooting such as temporary deactivating all plugins?

    Please let me know when you do so.

    Cheers,
    Sohag

  • Adam Czajczyk

    Hello Jessica,

    I took a liberty of checking your site, using credentials that you sent to my colleague Sohag.

    The first thing that I noticed was that the admin area isn't loading too fast. The second issue is that the debug log file that you provided us with contains a 599 HTTP error which is a timeout error. That error shows up when WPMU DEV Dashboard plugin tries to connect to our API and I suppose it happens during updates. Such a timeout issue might be caused by a number of reasons and since my colleagues already confirmed that the IP of your server is not blacklisted in out system, low memory resources might be the reason as well.

    That said, I started with enabling WP debugging on that copied (staging) site and increasing WordPress memory limit there to 256M by adding this line to the "wp-config.php" file:

    define('WP_MEMORY_LIMIT', '256M');

    Since we don't have access to Plesk, I could only try to update the plugin via Dashboard so I run a simple test: first, I downgraded Membership 2 Pro to the previous version manually (via FTP) and then I run bulk updated via "Dashboard -> Updates" page. That, however, went fine and the upgrade was successful. I'm still not sure though if that means that issue doesn't occur with this kind of updates or if raising memory limits helped.

    That said, I'd like to ask you if you could also send Plesk access credentials to Sohag (just like you did last time) along with a brief "step-by-step" instruction on how do you perform these updates through Plesk. I hope that this could help us catch up the issue if it's still there.

    Also, is it possible to switch PHP version from 7.0.21 to 7.1.x? The 7.0.21 version (all versions from 7.0.x) seems to suffer from some memory leaking issues which might be causing some problems.

    Best regards,
    Adam

  • Dimitris

    Hey there Jessica,

    hope you're doing good today and don't mind chim in here! :slight_smile:

    HI just to clarify, did you run this update to wp-config.php on http://tasteharborough.org/wordpress/

    I can see that my colleague Adam referred to the staging environment, so I guess that's true.
    I've also used the FTP credentials for this installation and confirm the increase of memory limit.

    The plugin has deactivated itself and the error messages shown in the attached image shows on the plugin page. SO, unfortunately, it hasn't worked. Any other ideas?

    There's no attached image in your previous reply unfortunately. Please give this another try (keeping in mind the upload limits of our forums in the "insert images" section) or use another service like Dropbox.

    Can you also provide some more feedback on this part from Adam's reply?

    That said, I'd like to ask you if you could also send Plesk access credentials to Sohag (just like you did last time) along with a brief "step-by-step" instruction on how do you perform these updates through Plesk. I hope that this could help us catch up the issue if it's still there.

    It's unclear to me also, do you update your plugins via Plesk panel or through the wp-admin area?
    Please advise!

    Warm regards,
    Dimitris

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.