Membership 2 Issues - Blog Page 'not found' and Having to login twice

When the Membership 2 plugin is enabled, I have the following issues...

#1 - The 'blog' page returns a 'page not found' error.

The page does exists and is not controlled by any Membership 2 setting and access control for that page is off.

I have tried...
#1 - Flushing the rewrite rules.
#2 - Disabling the 'Redirect Control' add on for Membership.
#3 - Disabling other plugins.
#4 - Reverting to the Twenty Seventeen theme.
#5 - Updating the Front Page to be 'Your latest posts"
#6 - Updating the Static Front Page and Blog page to something else.
#7 - Updating the Static Front Page and Blog page back to what it should be/is now.
#8 - Turning off Membership control (not disabling the plugin, truing off the control in the Membership settings.)
#9 - Disabling the Membership 2 plugin.

******* The only thing that fixes the issue is to disable the Membership 2 plugin. *******

#2 - I added the [ms-membership-login] shortcode to a page. When an admin uses that page to login, they are re-directed to the page I have setup in the 'Redirect Control'.

However, when they click on the Wordpress Dashboard link, they are taken to the actual WordPress login screen and prompted to login again.

Once they login the 2nd time, they can go back and forth between the dashboard and actual site and not have to keep logging in.

Note: If they log out and then use the page with the shortcode on it to log in again, the process starts all over.

I have tried...
#1 - Flushing the rewrite rules.
#2 - Disabling the 'Redirect Control' add on for Membership.
#3 - Disabling other plugins.
#4 - Reverting to the Twenty Seventeen theme.

******* Noting fixed the issue. *******

Please advise.

  • James Morris

    Hello Chris,

    I hope you are well today.

    Excellent troubleshooting!

    The next step would be to check for debug.log output to ensure there isn't an issue with the server environment that's causing an incompatibility.

    Could you please enable WP_DEBUG and provide us with the output of your debug.log file?

    To enable WP_DEBUG, change the following line in your wp-config.php file:

    define('WP_DEBUG', false);

    To this:

    // Enable WP_DEBUG mode
    define( 'WP_DEBUG', true );
    
    // Enable Debug logging to the /wp-content/debug.log file
    define( 'WP_DEBUG_LOG', true );
    
    // Disable display of errors and warnings
    define( 'WP_DEBUG_DISPLAY', false );
    @ini_set( 'display_errors', 0 );

    After you've visited the pages that are causing you problems, please go to wp-content/ on your server via FTP and download the debug.log file to your local computer. Then, open that file with a text editor like notepad (Windows), GEdit (Linux), or TextEdit (Mac). You can then paste the contents of that file at http://pastebin.com/ and share the URL of the pasted output with us so we can examine it further.

    I look forward to seeing the results of your tests.

    Best regards,

    James Morris

  • Chris

    Hi James,

    There are no errors in the debug.log file that are specific to either issue above. In fact, the only error in the log file ([16-Feb-2017 08:12:43 UTC] PHP Notice: Indirect modification of overloaded element of WP_Hook has no effect in .../snapshot/lib/WPMUDEV/Dashboard/wpmudev-dash-notification.php on line 58) is an on-going error that happens any time the WordPress Dashboard is accessed.

  • Chris

    Hello Ash,

    Great suggestion - not at this time though.

    I've been able to do more troubleshooting on Issue #1 and, if a role has the 'edit_theme_options' capability enabled, they will be able to see the blog page when they log-in and go to the dashboard (which forces them to login a 2nd time).

    Also, I created a brand new page and set that to be the posts page. Still got the 'page not found' error.

    I have (basically) all add-ons enabled and disabling them made no difference.

    When the 'special pages' add-on is enabled, the Blog Archive visibility is set to 'everyone' and it still doesn't work.

    I tried installing a few other plugins to force the blog page to be visible and nothing worked.

    I installed Membership Pro 2 on another site and it works just fine. Note: I've seen this happen before with other plugins and it turned out that the offending plugin had set an option and never unset it. So, a fresh install on a new system worked fine - however - even uninstalling and re-installing the plugin on the broken system still didn't work. In this case, a fresh install is not an option.

    The other interesting thing is that the page title shows up correctly on the web browser tab.

    If I enable membership protection on the Blog Index and try to access it while not logged-in, I am first re-directed to the login page and then, after logging in as a user with the appropriate membership level, I get 'Page Not Found'.

    I testing other special pages (like the Year Archive) and they work just fine.

    ******* One possibility is that the static posts page routine has somehow become altered so that only people with the 'edit_theme_options' capability enabled can see it.

    I've also done some additional troubleshooting on Issue #2 and, the issue gets weirder.

    It appears that, the reason the users have to log-in again is because they aren't fully logged into the system the first time. I discovered this while testing Issue #1. When I used the page with the shortcode to login as admin and then tried to access the blog page, I got 'page not found'. However, when I clicked on 'Dashboard' (yes, I had the admin bar) , logged-in the 2nd time (as administrator) and then tried to access the blog, it worked just fine.

    ******* Have you ever seen anything so strange?

    I'm going to continue troubleshoot and implement a workaround for my client.

    Please let me know your thoughts and suggestions also.

    Cheers,

    Chris

  • Luís

    Hi Chris ,

    Hope you're doing well today!

    I would like to apologize the extreme delay in the reply and all the problems it may have caused.

    The issue you are having it's a quite unusual and honestly, I never saw it before. I spoke with my teammate Ashok and unfortunately it's a quite hard to give any suggestion at this point without a deep investigation.

    If you are still having issues with this I will suggest you to create a clone of your site in a staging location and send us the FTP credentials so we can investigate it further.

    If you are interested, please send it privately through our contact form:

    https://premium.wpmudev.org/contact/#i-have-a-different-question

    Send in:

    Subject: "Attn: Luis Lopes"
    - WordPress admin username
    - WordPress admin password
    - Login url
    - FTP credentials (host/username/password)
    - Link back to this thread for reference
    - Any other relevant urls/information

    Cheers, Luís