membership 2 login not working

The Membership 2 logins are not working. On submit, they simply redirect to the current page with no error message or any other indication of what went amiss.

I noticed in some cases that the login boxes (in the widget in the right rail) would redirect to
http://lovegwinnett.wpengine.com/protected-content/login
That page didn't exist, so I created it, but this seems to have had no effect at all.

Can you advise? Thanks!

  • Ken Kimbrell

    Hello Ron-

    I tried several solutions as a workaround to no avail, and I was unable to replicate the issue on my lab site. Furthermore after deeper investigation, I decided to activate one of wordpress's default themes, to see if it would function as normal. Our Membership 2 plugin worked just fine with the default theme and redirected to the account page after logging in as expected. There does seem to be a conflict with the theme Divogue that you are currently using and our Membership 2 plugin. Does Divogue have an options setting for login? I was unable to locate any.

    Let me know how I can help :slight_smile:

    Take Care,

    Ken - WPMU DEV Support

  • Ken Kimbrell

    Hello Ron-

    I used the 2017 standard wordpress theme and was successful in logging in with no issues at all. Please see the SCREEN CAST

    Depending on the theme, there could be ajax call conflicts. I was just able to use the login form on google chrome with your theme and was successfully redirected to the membership page, VIA ajax . Could you please try clearing your browser and or sever related cache and see if your able to login?

    Also, for your "Sign in" link at the top of the site you had that linking to the protection page, I changed that to the account page. So you should be able to go to the top left of your site, click "Sign In" and it take you to the Membership 2 account login page. You should now be able to login and be redirected to membership page, VIA an ajax call.

    Let me know how this works for you!

    Take Care,

    Ken - WPMU DEV Support