Membership 2 not sending emails

I've been trying to test sending emails to members who have invoices added to their account using the automatic emails add on and nothing is going out.

I have tried adding a smtp proxy which I usually use (postman smtp) and its not making any difference when I run invoicing on test accounts.

Also I have added the tab in the help menu via the added code in wp-config.php file and there is nothing in there. Anything else that can be done?

I am using the most recent version of wordpress, and all plugins and have run the test with all other plugins deactivated and with the standard wordpress theme with no luck.

Please help, I'm stuck

  • Denitsa

    Hello Jessica,
    I hope you are having a great day!

    Also I have added the tab in the help menu via the added code in wp-config.php file and there is nothing in there. Anything else that can be done?

    I'm sorry, I'm a bit lost here, what code exactly did you add to the wp-config.php file? Was it define( "MS_LOG_EMAILS", true ); and so you're missing the Email history tab?

    Can you try downloading the patch I have attached to this post and replacing (you'd need to unzip it first) the /wp-content/plugins/membership/app/model/class-ms-model-communication.php with it?

    Let me know if this works for you!

    Best regards,
    Denitsa

  • Denitsa

    hello Jessica,
    I am sorry for any inconvenience caused.

    Just to be 100% percent sure your WP is sending out mails successfully every time, can you install the Check Email plugin? Then open it via Tools -> Check Email and send a test email to an address of your choice. Meanwhile, you can check the exact settings under Current email settings.

    It looks like our developers are already aware of a similar bug and a fix is underway, so we will probably see this one solved with the next plugin release.
    However, when I tested with the above patch on my sandbox, I can see those emails as being sent from the Email history tab and the user is receiving them, but not the admin, so in order to be sure we're talking about the same issue here, can you make a basic theme/plugin conflict test? To perform it, please follow all the steps described on a flowchart in this article (you may need to scroll the page down a little):
    https://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    Keep us posted!

    All the best,
    Denitsa

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.