Membership 2 Payment Gateway problem

I am trying to use manual payments for memberships. But when I try to signup at the admin side Membership > Billing page I can not see the "Mark as paid" option and also Gateway column only shows "-". And Memberships > Edit any membership, Details page shows nothing.

  • Ash
    • WordPress Hacker

    Sorry I missed the following:

    And Memberships > Edit any membership, Details page shows nothing.

    Would you please enable debug mode and check if there is any error? To enable debug mode please go to wp-config.php and change

    define( 'WP_DEBUG', false );

    to

    define( 'WP_DEBUG', true );
    define( 'WP_DEBUG_DISPLAY', false );
    define( 'WP_DEBUG_LOG', true );

    That will create a file called debug.log inside wp-content folder. Open that file, check the very bottom and you will see the latest errors. Please send me those.

    Have a nice day!

    Cheers,
    Ash

  • Ash
    • WordPress Hacker

    Hello there

    Please use your in your php.ini and set session.gc_probability to 0. And make sure you restart your server after making changes in php.ini file.

    If you don't have access to php.ini file, please consult with your host about this.

    Please let me know if it works for you then. Have a nice day!

    Cheers,
    Ash

  • Ash
    • WordPress Hacker

    Hello Karsten

    The server told me, that the changes are active instantly.

    The server can't apply the changes unless it is restarted. Did you manually restart your server?

    And if so, would you please make sure /tmp folder is writeable? You must need write permission of that folder to work with sessions. Please let us know about that.

    Have a nice day!

    Cheers,
    Ash

  • Karsten
    • Flash Drive

    Hi,

    I uploaded the file, cleared the cache but wasn't able to see any differences in manual payments. Does it mean, that from now on manual payments will be available, or that old memberships also get manual payments.
    Also "mark as paid" is also not available. But this might be due to the problem, that no payment gateway was assigned.

    Karsten

  • Karsten
    • Flash Drive

    Hello there,

    I created two new memberships, both with manual gateways (because I am still not public). I than registered two new user and assigned these two memberships to the users. Both have a trial period of 14 days. After the prial period, M2 sents an email to the user and stops the access. Until here everything is fine. But again, as described above, in the M2 backend there is no gateway assigned to the invoice and I don't have the "mark as paid" option pretending the user as paid the membership fee.
    After that, I have tried to put them manually into active. First I have "edit billing" set the due date to a future date. But that doesn't change the status to "active". I than changed the status to "paid" but this also doesn't change the status to "active" also. Finally I changed at "edit member" the status to "active" but after I saved changes the old status (pending) was set again.

    Can you help me? I grant you support access.
    Cheers, Karsten

    • Paul Kevin
      • Neo

      Hey there Karsten ,

      Hope you are well today and sorry for the late response on this.
      I managed to resolve one subscription but the other 2 seem to have no gateway assigned to them in the invoice, hence the status is not changing. This was fixed in version 1.1.2 that was released (not sure if you are using this version) but generally the gateway for the invoice needs to be updated. And invoice needs to have a gateway for the status of the respective subscription to change. Could you run this sql in your db
      update wp_postmeta set meta_value = "manual" where meta_key = "gateway_id" and post_id in(1795,1791, 1787);
      Make sure to change the wp_postmeta to match your db prefix.

      Warm Regards
      Paul Kevin

  • Karsten
    • Flash Drive

    Hi,

    I tried your database change but I got this error msg in myphpadmin:
    SQL-Command:

    UPDATE lb_ SET meta_value = "manual" WHERE meta_key = "gateway_id" AND post_id IN ( 1795, 1791, 1787, 1794, 1790, 1786, 840, 847, 813 )

    MySQL notifies:

    #1146 - Table 'db249048_27.lb_' doesn't exist

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.