Membership 2 Plugin IS KILLING ME!!!!!!

So I have had nothing but problem after problem with "The most powerful, easy-to-use and flexible membership plugin for WordPress sites available."

I am getting so fed up with basic things not working and the amount of bugs in this plugin!

I am trying to register users on devencenziag.com and am getting a sporadic error (happens every now and again but totally unacceptable)! This is happening in all browsers I test in:

That username is already taken, sorry.
That email address is already taken, sorry.

I know for sure the user name and email address are not in the system. I even tipple checked under Users => All Users & Membership 2 => All Members => All Users.

After the plugin throws the error a WordPress user is generated but that user is not given a membership with the plugin.

Please help me get this fixed!

Please also see this thread as it seems to be doing the same thing after a different error: https://premium.wpmudev.org/forums/topic/membership-2-registration-shortcode-not-working-with-ie

Support access is ACTIVE until October 25, 2015 10:17 am

William

  • Michael Bissett

    Hey @William, Michael here!

    I know that you mentioned that this was a sporadic error, but was there any sign of there being a pattern to when this behavior happens?

    I ask because I just tried registering accounts on your site, inside of:

    - Internet Explorer 11
    - Google Chrome
    - Firefox
    - Edge
    - Opera
    - Safari (on OS X El Capitan)

    And I was able to register an account successfully every time on my end.

    Please advise,
    Michael

  • William

    @Michael Bissett,

    There is no pattern. It has happened 3 separate times (twice with my client and once with me) with different user names and emails. I have cleared all the users twice hoping that this would solve the problem but it still happens. I'm not sure whats going on.

    I see all of your registrations and I can see they where all successful. Maybe this has something to do with registering with the Shortcode? I removed the shortcode this morning so you must have resisted on the "registration" page...

    My client is getting fed up with the problem and is not satisfied with the user experience he has had in the past two weeks (we have been trying to debug this). He has decided to put the membership section on hold for the time being and just let people view the section we where going to have the membership for until we can get the bugs worked all the way out.

    Thanks for digging into this for me and I would love to figure out what is causing the error because I am using the membership plugin on 4-5 sites right now.

    Thanks,
    William

  • Michael Bissett

    Hey @William, really sorry for the delay here! :slight_frown:

    I tried using the shortcode as you provided it here (swapping the ID of course), and I found myself able to register properly, so I'm curious as to why it wasn't working over on your end. :disappointed:

    I realize that you've disabled the membership functionality for the time being, but if you were to try re-inserting the shortcode onto a separate page, does it still not work over on your end?

    If it doesn't, then I'd like to have a closer look at things, could you please send in the following via our secure contact form:

    - Mark to my attention, the subject line should contain only: ATTN: Michael Bissett
    - Do not include anything else in the subject line, doing so may delay our response due to how email filtering works.
    - Link back to this thread
    - Include WordPress admin access details (login address, username & password)
    - Include FTP log-in details (hostname, username & password)
    - Include any relevant URLs for your site

    IMPORTANT: Please make sure you select "I have a different question" for your topic, so it doesn't go back to the forums - this and the subject line ensure that it gets assigned to me.

    https://premium.wpmudev.org/contact/

    Thanks in advance! :slight_smile:

    Kind Regards,
    Michael

  • William

    Hi @Michael Bissett,

    My client was getting the same error using IE7. I opened another thread about it here thinking it was a different issue (now I'm not so sure). @Ashok was able to confirm it as a bug.

    I am using Fire Fox and as I mentioned the bug is super sporadic and inconsistent so pinning it down has been a major issue for me.

    I have created a page for you to test on with the same shortcode that was giving me the issues.

    I have also sent you an email with all requested info.

    Thanks,
    William

  • Michael Bissett

    Hey @William, thanks for sending that in! :slight_smile:

    Thanks to the code wizardry of my colleague Ashok, we've got a patch available (which I've applied to your site), that I've found to resolve this issue in IE 11, as well as IE 7.

    I wasn't able to reproduce the Firefox issue (most likely due to the sporadic nature of the occurrence in that browser), but I have the feeling that this'll get that working too. :slight_smile:

    Can you confirm that it's working over on your end now please?

    Kind Regards,
    Michael

    P.S. For anyone else curious of the fix, I've attached the fix to the thread here, you'd want to take the file inside the attached .zip file, and upload it via FTP to:

    /membership/app/view/shortcode

    Replacing the file that's already there. :slight_smile:

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.