[Membership 2 Pro] Adding invitation code doesn't work since upgrade 1.1.2

Since Membership has been upgraded to 1.1.2, adding invitation code doesn't work.
Switched to 1.1.1 => it works
Switched to 1.1.2 => it doesn't work

SUPPORT ACCESS is active.

Thanks,
Frank

  • Majid

    Hello Frank
    I hope you are doing great today :slight_smile:

    I wasn't able to replicate the issue on my test site, adding new invitation codes worked as expected, So I would suggest making a plugin conflict test by disabling all the plugins except for WPMU DEV Dashboard and Membership 2 Pro.

    The simplest way to perform a plugin conflict test:
    * Login to your site via FTP
    * Navigate to wp-content
    * Rename the plugins folder to _plugins
    * Move the plugin folder (ex: membership) you want to test from _plugins to plugins
    * Then, one at a time, move other plugin folders over from _plugins to plugins until the symptom returns

    NOTE: While you are doing this, do not visit WP Admin -> Plugins on your site. This will ensure that your plugins remain active when you copy them back over.

    Let me know in a reply the results.

    Thanks,
    Majid

  • Nahid

    Hey Frank !
    Hope you are doing well today!

    I tried to replicate the issue on your site but I couldn't access it due to an HTTP authentication which requires a username and a password. Here's a screenshot for reference:

    Could you please send us the HTTP authentication credentials along with WordPress Admin and FTP credentials so that we can take a deeper look into the issue?
    You can send that privately through our secure contact form: https://premium.wpmudev.org/contact/#i-have-a-different-question

    Send in:

    Subject: "Attn: Nahid Mohit"
    -HTTP Authentication credentials (username/password)
    -WordPress admin username
    -WordPress admin password
    -login url
    -FTP credentials (host/username/password)
    -link back to this thread for reference
    -any other relevant urls

    Could you also try enabling debugging in the wp-config.php file so that we can try getting a general idea about the source of the issue? You can enable debugging by putting the following constants in the wp-config.php file:

    // Enable WP_DEBUG mode
    define( 'WP_DEBUG', true );
    // Enable Debug logging to the /wp-content/debug.log file
    define( 'WP_DEBUG_LOG', true );
    // Disable display of errors and warnings
    define( 'WP_DEBUG_DISPLAY', false );
    @ini_set( 'display_errors', 0 );

    These constants must be added before the line "/* That's all, stop editing! Happy blogging. */" for them to work. Please make sure identical constants are replaced if they were already there previously.

    Enabling debugging in WordPress will log any errors that the site encounters in a log file named "debug.log" located in the "wp-content" folder. Please upload the debug.log file in a cloud storage platform like Dropbox and attach the shared link in your next response so that we can take a look into it.

    You can know more about WordPress debugging in this handy article.

    We'll be looking forward to hearing back from you. Thanks!

    Kind regards,
    Nahid

  • Nahid

    Hey Frank !
    Hope you are doing well today!

    I'm extremely sorry about the delay in getting back to you about this issue, this slipped through the gaps somehow. I have received the credentials, thank you very much. There was a very recent update to the Membership 2 Pro plugin. Could you try updating to the latest version and see if that makes a difference?

    If that doesn't help, I'll instantly move on to some extensive troubleshooting tests as soon as I hear back from you.

    We'll be looking forward to hearing back from you. Thanks!

    Kind regards,
    Nahid

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.