[Membership 2 Pro] All pages gives a 404

Hi,

We want to hide some pages for non-subscribers. But when we activate the plugin all pages gives a not found message from the theme we use.

This happens for guests but also for subscribers who are logged in.

In the admin bar is the text “content protection is disabled” so pages should be visible..

Also disabled all other plugins but same problem.

Only solution was to deactivate Membership 2 Pro to get the pages back.

When we switch to the Twenty Nineteen theme there are no 404 messages, so it’s the theme somehow. The theme we use (Nexus Themes) can create their own content besides the WordPress content.

When visiting a page which contains f.e. a shortcode it is displayed but above it the message is displayed the page cannot be found.

Have there been other users with the same problem and can this be fixed in the plugin or should this be fixed in the theme? (I hope the first)

Gr, Age

  • Pawel
    • Staff

    Hello there!

    I hope you’re well today and thank you for reaching out to us!

    I’m sorry you are experiencing this issue. I’d like to check what is causing it and look for a solution.

    I haven’t seen any reports related to this issue, actually.

    Would you mind enabling Support Access to your site, so I can check what is happening?

    To enable support access you can follow this guide here:

    https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-5

    Please respond in this ticket once access is granted.

    Cheers,

    Pawel

  • Pawel
    • Staff

    Hello!

    Thank you for enabling Support Access. I managed to log in to your website. I activated Membership and confirmed that the issue is there. I couldn’t find any reason as to why this is happening, though – I’d like to investigate this a bit more, especially I’d need to gather some more debug data.

    As for the reports and after checking your website, I can’t find anything related or similar in our company channels.

    For me to be able to track the source of this issue, I will need to access the files on your server. Would you mind sharing FTP access with me so I can debug this?

    Note: Don’t leave your login details in this ticket.

    Instead, you can send us your details using our contact form https://premium.wpmudev.org/contact/#i-have-a-different-question and the template below:

    NOTE: Don’t change selected topic in the dropdown, just leave it at “I have a different question”.

    Subject: “Attn: Pawel Pela

    – Site login URL

    – WordPress admin username

    – WordPress admin password

    – FTP credentials (host/username/password)

    – cPanel credentials (host/username/password)

    – Folder path to site in question

    – Link back to this thread for reference

    – Any other relevant urls/info

    Kind regards,

    Pawel

  • Pawel
    • Staff

    Hello there!

    Thank you, I got the details and I started debugging. For now I can confirm that the theme is giving me the same message as you described, but that doesn’t happen when the default theme is enabled.

    I’ll move your case to our Second Line Support so they will take a look and see if we can do anything on our side or is this something that has to be fixed in the theme – due to the fact that this theme is using a custom framework.

    Kind regards,

    Pawel

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.