[Membership 2 Pro] Another error in the membership

In the list of users i have all the users in the wordpress like an active membership, but they havent any, when i access to the membershi list of active members i have only 8 users, and in the wordpress list of members i have all the members, i havent active any rol management for the membership...

Can you check this?
Because the users that had the membership active, every day the date of finish is updated with another 30 days... I dont know why this happened...

  • Adam Czajczyk

    Hello Diego Díez Corral

    I hope you're well today and thank you for your question!

    I have checked your site and it seems to be a caching issue rather than a bug. You're using LiteSpeed cache (hence, you must be using LiteSpeed webserver as well) which includes some "heavy" on-site caching and opcode cache (which is a special cache caching results of PHP code compilation). At the same time there's been internal Membership 2 Pro cache enabled ("Speed up results" toggle switch in Membership 2 Pro settings).

    When I disabled M2P internal cache and cleared LiteSpeed cache entirely, users on users list are no longer marked as having memberships. On a members list there's still 7 active subscriptions listed and additionally - when you browse through "All" tab of the Membership 2 -> All members page - you'll find out that there are couple of members still listed with membership but with no active subscription (if you check subscription details). That seems to be now consistent with the WP users list.

    The bottom line is - it seems that heavy LiteSpeed caching doesn't play well with internal Membership 2 Pro caching. Let's leave M2P "Speed up results" option switched off (as it is now) then.

    Additionally, I think you should follow a notice from one of the Mailster plugins (I don't know which one is adding it but it doesn't matter much, the message is important) that says:

    It looks like your last cronjob hasn't been finished! Increase the 'max_execution_time', add define("WP_MEMORY_LIMIT", "256M"); to your wp-config.php or reduce the Número de emails enviados in the settings

    It suggests that the WP cron is not fully working. If it's not able to complete some of the tasks (even unrelated to Membership 2 Pro) it might also be breaking on others (and Membership 2 Pro does use it) so please add the

    define('WP_MEMORY_LIMIT', '256M');

    line to the "wp-config.php" file of your site (make sure it's above the /* That's all, stop editing */ line).

    Your WP is currently limiting available PHP memory to only 64M while server allows up to 256M so with that complex Multisite setup raising it is a good advice.

    Once that's done, leave it for a while with current setting and let's see if the issue happens again. If so, let me know please (make sure that support access is still enabled then) and I'll talk to our developers as we might need to exclude some internal M2P tasks/hooks from LiteSpeed cache.

    Best regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.