Membership 2 Pro - Coupons Won't Turn on

Whats going on guys, First you break my coupons with your Membership 2 Pro (Version 1.0.3) update, and now I can't even re-enable coupons on your Version 1.0.3.1 update.

I roll back to Version 1.0.2.9 and it works again

---

Can you please implement some for of QA before releasing plugins, I understand errors happen, but this is not really workable, especially since my plugins auto updated and broke a rather large site.

Maybe an option with automatic updates to set the time delay before update (say 1-2 weeks for large important sites) or even setup a ReleaseCandidate system where by you send out all your plugins as RC for a week before setting them live, so it can be crosschecked and tested by members to pick up these errors.

  • Sajid
    • DEV MAN’s Sidekick

    Hi Braydan Willrath,
    Hope you are doing good today :slight_smile:

    I am sorry for inconvenience that may cause this. I tested it on my own site and could replicate this issue as well. I am marking it as confirmed bug and notifying the developer so it can be patched up as soon as possible. Please keep an eye on this thread for updates or you will also get updates notification in WPMU DEV -> Updates section.

    We do have internal Quality Assurance and testing to track down any hidden issues but it seems this issue slipped away. Sorry!

    I like your idea of sharing the RC/BETA with members to get their feedback and we have been doing this in the past. I will pass along this to the development team for consideration.

    Thanks for reporting the issue and have a nice day :slight_smile:

    Best Regards,
    Sajid

  • Braydan Willrath
    • Flash Drive

    3 days later and still no fix, C'Mon Guys, Surely you can do a bit better than that, this is effecting people's businesses and websites, this isn't a feature request, but a pretty big BUG that was seemingly caused by a lack of QA.

    Please get a move on and fix it ASAP.

  • Emily VonSydow
    • Design Lord, Child of Thor

    I just got an angry call from a client because the plugin auto-updated and broke the coupon code again. She had just told her customers that it was fixed, and now they look really bad that it isn't.

    This needs to be fixed ASAP. And I need to know how to disable auto-updates.

    I don't know what to do at this point--the client is so frustrated that she wants to move to a different plugin. She feels like this one is unreliable. That's so much wasted time for me and for my client.

  • Emily VonSydow
    • Design Lord, Child of Thor

    I saw that you guys released an update, even though this thread wasn't updated.

    I installed the update on my staging server through the WPMU Dev plugin. Now I can't activate or deactivate any add-ons. Is anyone else having this same issue with 1.0.3.2?

  • Sajid
    • DEV MAN’s Sidekick

    Hello All,
    Hope you guys are you doing good today :slight_smile:

    Please accept my sincere apologies for inconvenience and delay on this ticket. We recently released a new version of Membership 2 plugin that fixed this issue.

    Update Membership 2 Pro plugin to 1.0.3.3, clear browser cache and then enable/disable add-ons.

    Thanks for you patience and have a wonderful day ahead :slight_smile:

    Best Regards,
    Sajid

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.