Membership 2 Pro Generating Membership Type On Its Own

Hey,

I'm not sure what is going on with this but Membership 2 Pro has been auto-generating of one my membership types without me having prompted it to. I updated BuddyPress & Membership 2 Pro last week. Since having updated Membership 2 Pro all of a sudden, "Search Index," membership types are auto-generating (I've had up to 40/day, 1/day and sometimes 0/day). It already auto-generated one (which I deleted) today. It does not always do this but I have absolutely no idea as of to what's causing this or how to resolve this issue. I've just been deleting these new/ false, "Search Index," membership types as I I don't know why they're generating and I want to ensure that my site remains secure.

I can't seem to figure out where the issue lies but I believe it's related to/derived from either the BuddyPress or Membership Pro 2 updates I did last week.

Any help in figuring this out would be greatly appreciated.

Thank You!

~ Kathryn N. Sano

    Patrick

    Hi there Kathryn

    I hope you had a great weekend!

    That membership is being automatically added because you have enabled the Search Index addon under Membership2 > Addons.

    It is designed to allow you to grant access to search engines so they can index selected content that you have set as protected.

    If you don't want search engines to index any protected content, disable that addon.

    Kathryn

    Good Morning Patrick,

    I appreciate your feedback and have had that setting / membership type activated since I started using MP2 Pro years ago (as I do want search engines to be able to index but not display my protected content). This issue with the creation of multiple search engine index memberships auto-generating is new and I don't know why it is happening. Any further insight into this issue would be greatly appreciated.

    Thank you,

    ~ Kathryn

    Patrick

    Hi again Kathryn

    Oh dear, it looks like I missed the part where you said it was creating multiple Search Index memberships. Sorry about that.

    This is perhaps due to the fact that you have not yet defined the protected content that you want search engines to have access to in order to index that content. Please go to Membership > Protection Rules in your admin, and add the Search Index membership to all protected content that you want indexed.

    Let's see if that stops the thing from creating multiple copies of itself.

    Kathryn

    Good Morning Patrick,

    I appreciate your help however, I already did that when I set up my other membership types. I need an answer to why MP2 Pro is auto-generating this membership type (as it is the only membership type that is auto-generating) not basic answers regarding set up that I've already done. I understand that you're trying to help me resolve this issue however, your responses (albeit helpful to someone who just started using this plugin) are coming across as condescending (as I've used this plugin for a long time and this is a new issue) as you have yet to actually provide an answer that might solve the actual problem at hand. I appreciate your assistance, patience and understanding regarding my frustrations (mentioned above) in advance.

    That having been said, here was an update last week to the plugin. Do you know if there was a glitch or something with that update?

    Thanks,

    ~ Kathryn

    Patrick

    Hi again Kathryn

    I apologize if my replies hinted at any condescension; that was certainly not my intention. I was simply pointing out what I believed to be rather common omissions, like assigning the Search-Index membership to any protected content that you want indexed by search engines.

    Please do not take this as condescension, but I just double-checked on your site and see that membership is not assigned to any protected content.

    Also, I re-read your posts in this thread and I must have missed this:

    I want search engines to be able to index but not display my protected content...

    The Search-Index addon will both index your protected content, and display it in search results; that is the purpose of the addon:

    However, I have up-to-date Membership2 and BuddyPress running on a test site, along with a host of other plugins, and have been unable to reproduce this issue. The Search-Index membership that was created when I first enabled the addon is the only instance; no others have been auto-created at all.

    So I'm thinking there may be something else active on your site that may be interfering. I see you are hosting that site at GoDaddy. Can you please check your cache settings to see if there is any way to turn off object cache or transient cache? If there is no such option, please try the solution proposed here:
    https://ca.godaddy.com/community/Managing-WordPress/Disable-object-caching-in-PHP/m-p/33247/highlight/true#M2969

    Kathryn

    Good Morning Patrick,

    Thank you for your assistance I sincerely appreciate it. I'm officially confused as I had pages and posts protected (not many but I had them) and just checked my site and (like you said) nothing's there. Again, something weird is going on as I haven't done anything but monitor this issue since I put in my help request. I'd have to say this has officially reached the point of this being one of the strangest things ever!

    I've cleared my cache multiple times and the last time GoDaddy did anything related to caching on my site they not only crashed my site but then proceeded to tell me that my site must've been hacked. That having been said, what should I do regarding your recommendation of checking my cache settings to see if there is any way to turn off object cache or transient cache?

    Thank you again,

    ~ Kathryn

    Patrick

    Hi again Kathryn

    I hope you had a great weekend!

    According to that article I linked to in my previous post, look in your wp-content folder for a file named object-cache.php

    Rename that file to something else to disable that cache; perhaps rename it to DISABLEDobject-cache.php so it's easy to recognize later.

    We'll then see if caching from GoDaddy managed hosting is indeed interfering.

    Kathryn

    Hi Patrick,

    Apologies for the delay in my response. Since we last communicated with one another I had to restore my site (for other reasons) and discovered that my GoDaddy hosting associates one of my Admin accounts (not the one I was using) to Manage my Wordpress site. I didn't realize it until I was logged in through that account, removed the undesired/auto-generated membership types and I haven't had that issue (fingers crossed) since I did that. I'm honestly not sure what's going on. I will reach out if this issue returns though.

    As an aside, although this is a different (yet related) topic, I wanted to let you know that I am now having other issues on the site though. They're related to formerly protected categories not showing up to site visitors on my, "Blog." The Blog is my main posts page. If you check, "The Archives," they do show though with the appropriate categories and tags. I unrestricted all categories and tags in MP2 to see if those posts would appear on the Blog (which is not restricted and never has been) and for some reason site visitors still can't see them but on the admin side it shows everything with the appropriate tags and categories. I was planning on creating a new help ticket for this but I believe this is a MP2 Pro issue that most likely is related to the Search Index issue I was having. If you could please assist me in this matter and let me know if it would be best to open a new help ticket, it would be greatly appreciated.

    Thank You,

    ~ Kathryn

    Patrick

    Hi again Kathryn

    Good on ya for getting your site restored, and that it seems to have resolved the issue with those weird "ghost" memberships.

    As for the other issue, yes, it would be best to create a separate topic for that, as it is wholly unrelated to the subject of this one. But at first glance, it looks to me like a simple CSS issue in your theme, if I'm understanding you correctly.

    Do you mean that you want the categories & tags to show for posts on the Blog page? If so, all you need to do is set the entry-meta containers to display:block; rather than display:none; as they are currently.

    Your theme style.css currently has this rule in it:

    .has-post-thumbnail.excerpt-image-left .entry-meta, .has-post-thumbnail.excerpt-image-right .entry-meta, .blog .format-aside .entry-title, .archive .format-aside .entry-title, .byline, .updated:not(.published) {
        display: none;
    }

    Add a bit of custom CSS to override that and change it to display:block; and your categories & tags will show up.

    .has-post-thumbnail.excerpt-image-left .entry-meta, .has-post-thumbnail.excerpt-image-right .entry-meta, .blog .format-aside .entry-title, .archive .format-aside .entry-title, .byline, .updated:not(.published) {
        display: block;
    }

    You can add the CSS to any custom CSS area in your theme, or the WordPress Customizer, or use a handy little plugin like this one:
    https://wordpress.org/plugins/simple-custom-css/

    Here's your Blog page now:

    ...and here's what it would look like with the tags & categories... there are lots!