Membership 2 Pro hides menu items

As a non logged user, Csapataink menu item will show up in the main menu when MS2 is deactivated, however when it's enabled that item becomes hidden and another one shows up. the issue is that I don't have any memberships.

  • Adam Czajczyk

    Hi Bela

    I hope you're well today!

    I checked the site but I must say it seems to behave in yet a different way for me than described: the U11 link did show up at first when I visited the site as a logged out user while Csaptaink link was showing while I was logged in as an admin - regardless whether the Membership 2 Pro was enabled or not.

    I can see in "Protection Rules" that there are items (including those in question) that were previously protected by some memberships but those memberships were deleted. While that should cause all these items to be visible there's one thing worth trying before going any further:

    - mark (check check-boxes next to them) all the affected menu items
    - use "Drop all memberships" option from the drop-down selection box above the list
    - and there if there is any cache whatsoever on the server, clear that cache entirely and check the site again.

    Let me know about the result. If it doesn't change anything, we'll investigate it further.

    Kind regards,
    Adam

  • Adam Czajczyk

    Hello Bela

    Thank you for letting me know.

    Yes, in that case that would require further testing but I'm afraid I can't replicate that on my end. Since you have deactivated the plugin - will it be possible for me to activate it back and do some more tests?

    If this would interfere with what you're doing, perhaps you could set a staging site for us (a "1:1" copy of the one in question, on the same server) and grant us access to it so we could do some testing there?

    Let me know, please.

    Best regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.