Membership 2 Pro not protecting any content

Why is our blog showing when Membership 2 Pro should be protecting it? In fact, no matter what we try to protect with your Membership software it DOES NOT WORK. We used the simple default member which was seemed like a great solution for us. We applauded the simplicity of the install and setup and loved the ability to test as a member. Unfortunately the plugin is not protecting the content as follows;

Setup correctly as follows;
https://www.evernote.com/l/AVzsN_yEAjdLz6MW7xuybxhA_oGwNm8IRJY

NO PROTECTION as follows;
https://www.evernote.com/l/AVw5c8EydvJOM6ozZMovDBZoAuBF53Hlz0s

Pleas advise ASAP. Thank you

  • Luís

    Hi Scott Howard ,

    Hope you're doing well today!

    I tested this on my install and I was able to replicate. The issue is related to the "Default Membership" in the simulation mode.

    A "Default Membership" allows to protect content to the logged out users and make it available only to all logged-in users that did not join any other Membership.

    However, in the simulation mode you only have the option to view as "No Membership / Visitor", that, from what I understand, it don't make the distinction between a user without a membership (can be a logged in user) and a visitor (logged out user).

    So, as the "Default Membership" makes the content available to logged in users without a membership, in the simulation mode, as you are logged in, it don't protect the content.

    But, from what I tested in my install, this only happens in the simulation mode. If you open the page in a private window, where you are viewing the site as a Visitor, it should displays the protected content message and the form to Login/Register. Have you tried it?

    I am not totally sure if this can be considered as a bug, or it's the way it was designed, joining the "No Membership / Visitor" together. I will ping the developer to get more information.

    Cheers, Luís

  • Luís

    Hi Scott Howard ,

    Glad to know that is working properly in "live" mode :slight_smile:

    However, after spoke with the developer, this shouldn't be considered as a bug, this is the way the simulation mode was designed.

    But you are right, this is confusing and we should work in a better way to deal with this, maybe creating a separate option to "No Membership" and other to "Visitor", instead of both together.

    So, I've just moved this over to our Features and Feedback section, so it can be taken into consideration for the next plugin updates.

    Cheers, Luís

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.