Membership 2 Pro not working

HI,
My site got a HTTP 500 error and went down. Our host - dreamhost said it was the Membership 2 Pro plugin. We deactivated it.

The error could be found so we started fresh and deleted the plugin folder for Membership 2 and reinstalled.

When we activated the Membership 2 Pro (new install), we got the HTTP 500 error again.

Please advise.

  • Nithin

    Hi Chad Thorp,

    Hope you are doing good today. :slight_smile:

    I'm not able to replicate such issue in my system, this could be an issue specific to your website. However, I checked your system, and Membership 2 Pro plugin seems to be activated, have you fixed this?

    If you still encounter 500 internal error, could you please try increasing your memory limit, and check whether that helps. To increase your memory limit, you'll have to create a php.ini file inside your root directory, and add the following rules to it:
    For eg:

    upload_max_filesize = 128M
    post_max_size = 256M
    memory_limit = 512M
    file_uploads = On
    max_execution_time = 180

    If you aren't able to increase your memory limit, would recommend you to get in touch with your host, in order to increase these values.

    Please check this link for more info:
    https://premium.wpmudev.org/blog/increase-memory-limit/

    Please let us how that goes, have a nice day. :slight_smile:

    Kind Regards,
    Nithin

  • Nithin

    Hi Chad Thorp,

    Since you did mentioned that your entire site went down, I didn't check by enabling Stripe. This might be related to bcmath library not enabled in your system. Could you please check whether this is the case? If you aren't sure, you'll have to check this with your host, so that they could enabled it from your side.

    Please do note that, Stripe Live payment gateway, requires your website to have SSL enabled, only test mode will work in http protocol.

    If bcmath is already installed, in your server. To troubleshoot it further, would recommend that you please enable debug mode. To enable it, open your wp-config.php file located in your root directory, and look for define(‘WP_DEBUG’, false);. Change it to:

    define('WP_DEBUG', true);

    In order to enable the error logging to a file on the server you need to add:

    define( 'WP_DEBUG_LOG', true );
    define( 'WP_DEBUG_DISPLAY', false );

    After making the above changes, please try to replicate the issue. The related errors will be saved to a debug.log log file inside the /wp-content/ directory.

    Please attach these in your next reply in txt format file, so that we could give a closer look. You can find more details about debugging here.

    Please let us know how that goes, have a nice day. :slight_smile:

    Kind Regards,
    Nithin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.