Membership 2 Pro Send Confirmation email to administrator not working

On the Bootcamp membership/automated email responses, there is a checkbox below it that says "Send copy to Administrator". It used to have a drop down that contained email address of users marked administrator. Now it has what is in the attached image. It looks as if the shortcode is broken? I'm on WPEngine. WP is up to date. All plugins are up to date.

Thank you,
Delegate

  • Kasia Swiderska

    Hello Mike,

    I've tested jus now Membership 2 Pro and that fields works fine on my site. This could be some type of conflict - please run a quick plugin/theme conflict test as illustrated in getting support manual (flowchart). Let me know how it goes.
    http://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    If test will not give positive results please grant support access so we can have a closer look at this?
    To enable support access you can follow this guide here:
    http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    kind regards,
    Kasia

  • Kasia Swiderska

    Hello Mike,

    On WPEngine difference between live site and staging is cache. But cache should be turned off for logedin admin, so this should not make a difference.
    I tested again membership 2 pro on WP Engine test site and I wasn't able to replicate this issue.
    Can you grant support access to your staging site? I would like to compare everything to see if we are not missing anything.

    In the meantime could you enable debug log in on your live site - I'm hoping this could tell us more about nature of that issue. To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

    define('WP_DEBUG', true);

    In order to enable the error logging to a file on the server you need to add yet one more similar line:

    define( 'WP_DEBUG_LOG', true );

    In this case the errors will be saved to a debug.log log file inside the /wp-content/directory.

    Depending on whether you want your errors to be only logged or also displayed on the screen you should also have this line there, immediately after the line mentioned above:

    define( 'WP_DEBUG_DISPLAY', false );

    The wp-config.php is located in your WordPress root directory. It’s the same file where the database configuration settings are. You will have to access it by FTP or SFTP in order to edit it. I would need then to see contents of the debug.log file - so please upload it to dropbox like a service and past here link.

    kind regards,
    Kasia

  • Kasia Swiderska

    Hello Mike,

    I'm creating task for our Second Line Support - our special coding forces. They will probably need FTP access to your site. Could you please send in the following via our secure contact form https://premium.wpmudev.org/contact/ :

    - Mark to my attention, the subject line should contain only: ATTN: Kasia Swiderska
    - Do not include anything else in the subject line, doing so may delay our response due to how email filtering works.
    - Link back to this thread
    - Include WordPress admin access details (login address, username & password)
    - Include FTP log-in details (hostname, username & password)
    - Include any relevant URLs for your site

    IMPORTANT: Please make sure you select "I have a different question" for your topic, so it doesn't go back to the forums - this and the subject line ensure that it gets assigned to me.

    Please confirm in thread that mail as send. Thanks

    kind regards,
    Kasia

  • Milan

    Hello Mike

    Hope you are well today and won't mind me chiming here.

    I can confirm that we have received your credentials. I've already updated report Kasia has created for you with these credentials. Hopefully very soon our SLS team would check about your issue and you'll be updated about troubleshooting. Please note that our SLS team works daily on critical issues and bugs so if for some reason you did not hear from them very soon, please wait bit longer. We appreciate your patience.

    Kind Regards,
    Milan

  • Lindeni Mahlalela

    Hello Mike,

    I hope you are having a good day so far. I would like to say thank you for your patience while we were working hard to solve this issue.

    I have good news for you. We have found the issue that was causing the email addresses not to show as expected on your settings page. The issue was in fact related to CloudFlare's email obfuscation service which is designed to protect email addresses from being harvested by bots. So because your website data is passing through CloudFare before it can reach the user, CloudFlare injects some code to the content to protect email addresses from being harvested by bots. That is the code you were seeing in the drop down list instead of seeing the email addresses.

    There are two solutions to this problem as outlined in Cloud Flare's Email Obfuscation feature support page. The first option is to turn off email obfuscation which I believe you turned on for a reason and the second one is to add the HTML comments below around the HTML element containing the email address, these comments tell CloudFlare not to obfuscate the email addresses.

    For your convenience, I have added the HTML comments to the settings page as follows:

    Added before select element containing the email addresses
    <!--email_off-->

    Added after the select element containing the email addresses
    <!--/email_off-->

    Since Membership 2 Pro plugin does not have hard coded HTML elements, this has to be done on the file 'wp-content/membership/app/view/settings/page/class-ms-view-settings-communications-page.php' inside the function 'get_fields()' at line number 613.

    Replace the code that looks like this:

    'cc_email' => array(
    	'id' => 'cc_email',
    	'type' => MS_Helper_Html::INPUT_TYPE_SELECT,
    	'value' => $comm->cc_email,
    	'field_options' => MS_Model_Member::get_admin_user_emails(),
    ),

    Change it to:

    'cc_email' => array(
    	'id' => 'cc_email',
    	'before' => '<!--email_off-->',
    	'after' => '<!--/email_off-->',
    	'type' => MS_Helper_Html::INPUT_TYPE_SELECT,
    	'value' => $comm->cc_email,
    	'field_options' => MS_Model_Member::get_admin_user_emails(),
    ),

    So basically I have added the two lines:

    'before' => '<!--email_off-->',
    'after' => '<!--/email_off-->',

    You may add these two lines in any similar fields where you are having problems with emails not displaying correctly.

    Please note that on your website I have already done this for you and you do not need to repeat it. So the results after this change are like in the screenshot below (I have hidden the email addresses on purpose)

    Please note that this is a fix so that you can use the plugin as you should and it is not yet planned for inclusion in the next update of the plugin. So keep in mind that the my changes may disappear on the next update. I have written details here so that you may be able to apply the fix in case some updates override the changes I have made.

    I hope you find all this useful and hope you enjoy your day further.

    Cheers,
    Mahlamusa

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.