[Membership 2 Pro] Shortcode Disabled

When I activate membership 2 to protect content, the shortcode stops working on the homepage and another page that uses shortcodes. So then the content cannot display without the shortcode. Was working fine now just stopped.

  • Sohag Ronjon Dey

    Hi Emmanuel,

    Hope you are doing well :slight_smile:

    I have gone through you home page settings and could not find any settings in the editor. This seems to be loaded using code in template. I have also checked the Membership 2 > Protection rules for pages and I can see there are two pages set as protected. Then I checked the page for the logged in user and for not logged in user and it shows the same content. According to the plugins default behavior the page should redirect to the protected content page which will show the login form to sign in.

    I have tried to replicate the same in my test site and could not replicate it there. In my test site I have set a page as protected and when I visit it as non logged in user it redirects me to the protected content page which asks me to signin to view the page. I have added shortcode (a gallery shortcode and a plugin shortcode like contact form 7) to that page and I can see the contents of the shortcodes are showing when I am logged in as a member. Which suggest there may be any conflict with any plugin or code at your end.

    May be a plugin conflict test help here. You can run the test as outlined in the flowchart below. This will eliminate the possibility of a conflict with another plugin.

    https://premium.wpmudev.org/wp-content/uploads/2015/09/Support-Process-Support-Process.gif

    Please make sure to take complete backup of your site files and database before making any deactivation/removal of any plugin or theme or kind of update or changes. This will help to get back to current state if any breaks or any settings misses.

    Is this the issue you are mentioning here? If not it will be helpful if you clarify a bit more about the issue. May be steps to replicate the issue. Also screenshots to understand the issue a bit more.

    I can see in your protected pages you are using a shortcode from a custom plugin. It will be helpful if you provide your ftp or cpanel access also so if needed we can also download and try to replicate your issue at our end. Please use the form in this url

    https://premium.wpmudev.org/contact/#i-have-a-different-question

    using this template:

    Subject: "Attn: Sohag"
    -WordPress admin username
    -WordPress admin password
    -login url
    -ftp credentials (host, username, password, port, path)
    -link back to this thread for reference
    -any other relevant urls

    Select "I have a different question" for your topic - this and the subject line ensure that it gets assigned to me. Please DO NOT post the credentials here as this is a public forum

    We will be looking forward to your reply.

    Wish a very Happy New Year.

    Cheers,
    Sohag

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.