[Membership 2 Pro] Small fixup required in membership 2 forms

Hi there,
I would need 2 adjustments on the membership 2 plugin on revatis.eu

You will find a screenshot video on my google drive, cause I think that it would be the quickest way to communicate what I was talking about :
https://drive.google.com/file/d/1Skrj99DoHzUqm8CxM4Bshfyrqt6xoCMA/view?usp=sharing

I have currently given support access to Katya Tsihotska as a network admin on https://eqscience-south-africa.com (the main network site)
Let me know if I can assist with anything else.

Edwin

  • Adam Czajczyk

    Hi Edwin

    I hope you're well today and thank you for your question!

    Please do not ever post any access credentials here. This is a public forum and posting logins and passwords here makes them publicly available. For the start, it's usually sufficient enough to simply enable support access to the site by going to the "WPMU DEV -> Support -> Support Access" page in site's back-end and clicking on "Grant support access" button there. If we need more direct access (admin login and password, FTP access or similar) we ask you to send them directly to us and provide you with an instruction on how to do this.

    That said, I have already edited your post and removed the credentials but I'd strongly recommend either changing password to that account or even removing it (if it was created just for us) as soon as possible.

    As for the login form registration link.

    The "register" button/link is a function of a login form shortocde. On your site there was "register=no" attribute added to the shortcode. I have edited the homepage and in a relevant Divi text block changed "no" to "yes" for "register" attribute of the Membership 2 Pro form shortcode.

    The register link doesn't look like a button "out of the box" so I have also added some simple, basic CSS to your site:

    .home .ms-membership-form-wrapper a:not(.lost) {
      color:#006189;
      display:block;
      width:88%;
      text-align:center;
      border:1px solid #006189;
      padding:8px 6px;
      margin:0px 20px 15px 20px;
    }

    Please feel free to tweak it to make the button better suit your expectations/site design. You'll find it in "Additional CSS" section on "Appearance -> Customize" page in the site's dashboard.

    As for the registration page.

    The "mess" is caused by "not specific enough" (too "general") CSS selectors used in some custom CSS added to the site (coming from "stylenew.css"). One way is to try to tweak them and another one - probably faster/simpler - would be to add this CSS to the site:

    #ms-shortcode-register-user-form .wpmui-checkbox-caption a[title="account"] {
        float:none;
        margin-right:0;
    }

    You can add it via "Appearance -> Customize -> Additional CSS" and it shoudl do the trick. Give it a try, please, but also make sure that after adding it you have cleared cache on site as otherwise you might not see the changes.

    I hope that helps! If you have any additional questions, let me know please.

    Best regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.