[Membership 2 Pro] You are logged in as, not showing

Hi
I have set up the membership for my members to login to, but when logged in the message only reads 'You are logged in as . Logout'
Why is the username not showing?
Thank you.
Neil

  • Adam Czajczyk
    • Support Gorilla

    Hello Neil

    I hope you're well today and thank you for your question!

    I see that you have enabled support access to the site so I accessed it and wandered around the site's front-end. Via a support access I'm actually logged in "as you" (WP sees me as your admin account) and whenever I saw the "You're logged in as..." message it was showing me your user name there - so that seemed to be working fine.

    Can you tell me please then:
    - are there any specific places on site/pages which I should check or for you it happens everywhere?
    - does it happen to all users or should I actually sign up as a regular member to be able to see that?

    Also, have you tried - just to test - checking after clearing browser cache and/or using a different browser?

    Let me know, please.

    Best regards,
    Adam

  • Neil
    • WPMU DEV Initiate

    Hi

    Sorry for the delay, have been away for the long weekend.

    I have tested this on a local version of the site, whist when i logged in it did display my username, there are styling issues with the logged in box, and if you enter incorrect details as well.

    I attach some screen shots.

    Thanks
    Neil

  • Neil
    • WPMU DEV Initiate

    Thank you

    I have another question on the functioning of the members area

    We have the signup form here: http://spreadeaglesailingclub.co.uk/register/

    But when people sign up, the are made a member of the site before the put the invite code in. This means anyone is able to sign up as a member to the site. I appreciate they cant see the hidden content, but we only want club members to be able to sign up, how can I prevent other sign ups, if i turn off the wordpress setting, no-one can sign up?

    Thanks
    Neil

  • Predrag Dubajic
    • Support

    Hi Neil,

    I'm afraid that this is currently the default M2 behavior and it can't be changed without some custom coding.
    Invitation codes are to limit access to certain memberships but before the membership is selected and assigned you need to have WP account registered, so once you get to the part of registering to selected membership your default WP account is already created.

    Membership 2 does use default WP functionality for registrations so using a plugin for invitation code should work fine to ask for code during account registration.
    This one was working in the past https://wordpress.org/plugins/baw-invitation-codes/ but the development is dropped so I would suggest searching for a similar plugin that is still being developed.

    What you can also do is edit your registration page and use WP password protection option so only users will password would be able to load the registration page.

    Best regards,
    Predrag

    • Neil
      • WPMU DEV Initiate

      Thank you for your advice there Pedrag, I like the idea of making the page private, as we are invite only for members this will work for us.

      How are the developers getting on with the 'logged is as issue' my clients are pushing me a bit on this one.

      Thanks
      Neil

  • Predrag Dubajic
    • Support

    Hi Neil,

    I'm afraid that at the moment I don't have any further info from the devs about the fix.

    As a temporary workaround, we can bring the functionality from 1.1.5 version back so it will show "Wrong username or password" message instead of the new one that's added in 1.1.6.

    I've made this change so all you need to do is download the attached file, unzip it, and place it inside wp-content/plugins/membership-pro/app/core/ folder and that should be it.

    Best regards,
    Predrag

  • Neil
    • WPMU DEV Initiate

    Hi Predgrag, that sounds worse than we have. Is there anyway of changing the message temporarily, either in the PHP or language file to just say 'You are logged in' and leave of the 'as .' this would be a cleaner solution for now?

  • Predrag Dubajic
    • Support

    Hi Neil,

    I believe there was a misunderstanding from my previous message, sorry I wasn't clear enough.
    The change I made didn't revert the fix username, it just affects the error message for wrong login details.
    In 1.1.6, in addition to "Logged in as" fix, there's also change for the error message during login, and I only reverted the second one.
    So username will still be shown and it will use previous error message that doesn't have any rendering issues.

    Best regards,
    Predrag

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.