Membership 2 Pro's billing & membership status not updating despite successful Stripe subsc

Hi.

I am using Membership 2 Pro with Stripe as my payment portal, and I am having an isolated communication issue between Stripe’s subscriptions and Membership’s invoices.

While testing my site, when I sign up a new User to a Membership that involves multiple payments via Stripe’s subscription portal, the first payment goes through smoothly with both Membership 2 and Stripe. However, Membership 2 will not reflect subsequent successful Stripe subscription payments in either its billing or membership status & permissions. So the User ends up being successfully auto charged for the 2nd payment, but their Membership status reflects an unpaid invoice.

I’ve done some troubleshooting already and the issue seems to involve a miscommunication of invoice #’s between Membership 2 & Stripe.

Please help! Thanks!

  • Jude
    • DEV MAN

    Hey Cody

    Hope all is well with you !

    This looks like a known issue and our developers are working on a fix for this. That said we do have a hotfix out which you can try

    https://db.tt/XdvPUCZV

    Also a note of caution, this is a beta version, while unlikely it may not be 100% stable and may evolve and change a bit before the final release. Its more of a temporary workaround as opposed to a long term solution

    Cheers

    Jude

  • Jeff VanDrimmelen
    • Design Lord, Child of Thor

    Was this rolled out in the latest updates? I have been having this issue an am running Version 1.0.3.5 (updated today) and just trying to make sure subscriptions are going to get recorded in the site like they should. All is running well on Stripe side… it is just not updating the expiration date on the site…

    Do I need to configure a webhook or something? Or should just putting in the settings work?

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.