Membership 2 updated - no protection for last articles

Hey

I have updated the last version of Membership2
On the Home Page all the last articles were protected correctly: only members can see the last articles allowed to them

Now anybody can see last articles, the protection is only when we enter in the article it asks for a password

Is there any way to restaure this ?

Thanks in advance

  • Tyler Postle

    Hey schmelnitzky,

    How are you protecting the posts? Are you doing it on a post by post basis or categories?

    The way I read this is that it use to hide the posts to only your members on your home page but now everyone is able to see them?

    Membership 2 doesn't have a password protection option so you must be setting that on the post itself using the default WordPress protection options?

    If you could grant support access then we would be able to review your protection settings and try to replicate this on our own sandbox sites :slight_smile:

    You can grant support access via WPMU DEV > Support > Support Access > Grant Access.

    I see you also have some additional authorization required to view your site. If you want to send the credentials for that in privately then you can send them here: https://premium.wpmudev.org/contact/

    Select "I have a different question" and make the subject line "Attn: Tyler Postle". This ensures it gets assigned to me :slight_smile:

    Look forward to hearing back!

    Cheers,
    Tyler

  • schmelnitzky

    Thanks for your answer!

    How are you protecting the posts? Are you doing it on a post by post basis or categories?
    --> By post category

    Membership 2 doesn't have a password protection option so you must be setting that on the post itself using the default WordPress protection options?
    --> No sorry I mean login: when you click on the protected article you must login. I would like that in last news sections: the visitors (not logged in) can't see the article, not at all. In last articles people shoud only see the tubnails and titles of what they are allowed to read. At the moment they can see all articles and must login to read it but they have seen tubnail, title and excerpt of the article. This I don't want

    I just sent you login details

    Thanks in advance

  • Tyler Postle

    Thanks for the quick reply and thorough description!

    I've tested this out further on my install and confirm that since the latest release it is showing those posts in the blog feed when it shouldn't be.

    I'm flagging the developer on this so we can get it fixed up as soon as possible :slight_smile:

    Either myself or the developer will reply back here once the fix is pushed out.

    If you have any further questions in the meantime just let us know.

    Cheers,
    Tyler

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.