Membership 2.1.2 - Not working (HELP)

Sorry, I also put this request at the bottom of an already existing thread, but am not sure if that thread is dead. My apologies upfront if this is a duplication.

----------------------------------------------------------------------------------------------------------------------------------------------------

Hi there,

I am trying to do a very simple thing. I have the 2.1.2 installed on the following site
http://www.quitforum.ca

where we are trying to have the content of a specific page just available to registered users. So we created an access level called "Non Registered Users" and then added that specific page to the "negative rules".

Then under options, we have selected "Non Registered Users" as the stranger level and added a protected content page that will give them the message when they try to access the page to register on the site.

It works well when I test it using the my admin account, but does not seem to be working for any other user. Can you please point out what I am not doing right.

The client is kind of getting impatient now. Many thanks upfront.

Sincerely,
OAK

  • Barry

    It works well when I test it using the my admin account

    It shouldn't work at all with your admin account as the membership plugin isn't running when you are logged in as a membership admin user so that makes me think something else is happening.

    Can you confirm that you have enabled the membership plugin on the dashboard? When you say that it does not seem to be working for any other user - what exactly is the behaviour you are seeing?

  • oakcomputing

    Hi Barry,

    First off, you guys rock :slight_smile: ... thanks for the prompt reply.

    So, basically, when I test it using the admin account, it works ... but now that you mentioned it ... I can see the blocked page because the the plugin is not running when I am in that account.

    So, my problem is that it is not working for me, and I am not sure what I am doing wrong. As I mentioned, I want to hide the following page "http://quitforum.ca/cphas-quit-practice-tools/" from strangers (i.e. unregistered users). But it wont show even for logged in users, and it keeps going to the "access not allowed". What I have done is:

    1) I created an access level called "Non Registered Users" and then added the above page to the "negative rules" so it wont be available to users who are not registered with the site.

    2) Then under options, I selected "Non Registered Users" as the stranger level and added a protected content page that will give them the message when they try to access the page. It prompts them to first register on the site.

    In my head, that should limit the page to people who are registered users on the site. Am I not doing something right here?

    Many thanks again. Really appreciate your help.

    Sincerely,

    OAK

  • oakcomputing

    All users who are registered with the blog are assigned to the level "Registered Users". Registered users have all pages in their positive rules.

    The other level is "Non Registered Users". Non registered users have all pages in their positive rules except for the page I do not want them to have access to.

    Under options, "Non Registered Users" is set as the "stranger" level.

    What am I still doing wrong?

    Sincerely,

    OAK

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.