membership

Hi, I have set up the member plugin – i have set up three plans – visitor – semi member and full member –

I have selected what members can see but it is not hiding of areas – can i have some help

The site is http://www.bleachingtrayacademy.com

  • PC
    • WPMU DEV Initiate

    Hello Craig,

    Greetings and thanks for posting on the forums.

    I have selected what members can see but it is not hiding of areas – can i have some help

    We will gladly help you with the same.

    first of all, did you go throughout he Membership plugin manual : Its here : https://premium.wpmudev.org/wp-content/uploads/2010/05/Membership-Documentation-SJC.pdf

    That will help explain how levels are created.

    Once you have gone through that, if that does not cover what you need, please let me know and I will assist you further.

    Cheers

    PC

  • Craig
    • Design Lord, Child of Thor

    ok – i see the other post was resolved – i will use this thread….

    Ok – i am logged in.

    So, I have looked at the pdf – and i have set up the different levels

    they are active

    the catagories are not blocked off though

    i had a member solution in place – and have some paying members – i changed over to your member plugin and now i cant get it working…

    i have had to hide the catagories from the sidebar – so they are no longer accessible and the last member to sign up is not very happy…

    i was trying to have three levels (or 4 if visitors is a level)

    Full

    semi – 2 payments – i will limit the videos they can see till the second paypemtn

    free – only watch some vids

    and visitor

    can you take a look please? see what is wrong?

    I tried working it out before contacting support – i even treid to delete the plugin and re-install.

    I am using this plugin as I then want to add the affiliate plugin

  • Craig
    • Design Lord, Child of Thor

    Hi, I am not very happy with the level of support – it was the deciding factor when joining – but after being in a dialogue with a couple of emails after a few minutes I have been waiting for over an hour

  • Craig
    • Design Lord, Child of Thor

    UPDATE

    I have managed to hide the areas from visitors – few challenges here

    1 – My category widget is showing in the sidebar – but it says no categories – this is no good as it makes the site look like it is un-finished…I need the categories to show but when clicked on should say members only.(like it did before i switched over to your plugin – was using another one…but did not have levels) This is the selling point – showing people what they get…

    2 – If you click the equipment link it says – “the content you are trying to access is available to memebers only – THIS IS GOOD….why doesnt the “choose your machine” link say this – instead it says “Apologies, but no results were found for the requested archive. Perhaps searching will help find a related post.” This is no good as it makes the site look broken…the difference betwwen the 2 is the the first is a page and the second is a post….

    3 – as mentioned above – visitors cannot have access to the equipment page – when logged in as a free visitor the option of showing this page is not selected – why does the page show?

    4 – the system is not sending out the welcome email

    5 – where is a client meant to log in? i have tried creating alink on the register page but it will not display

    6 – what is the normal timeframe for an email to come back from support – please let me know so i can plan around this. As i mentioned the reason i joined is cause the support was meant to be second to none. I hope there has been a glitch in the system which caused a dely – and that this is not normal – I invested in you and decided to switch over as I need an affiliate solution – im dreading pluging that in now.

    waiting to hear from someone

    thanks

    Craig

  • PC
    • WPMU DEV Initiate

    Hello Craig,

    Greetings and thanks for posting back.

    i had a member solution in place – and have some paying members – i changed over to your member plugin and now i cant get it working…

    The plugin does not integrate with memberships created by other plugins. If you had a previous solution, you will need to manually assign the previous members to the corresponding levels.

    i was trying to have three levels (or 4 if visitors is a level)

    Full

    semi – 2 payments – i will limit the videos they can see till the second paypemtn

    free – only watch some vids

    and visitor

    You will need to create 4 subscription plans and corresponding access levels.

    1: Full

    2: Semi

    3: Free

    4: Basic or whatever you name it.

    then the levels will be assigned to subscription plans accordingly.

    1 – My category widget is showing in the sidebar – but it says no categories – this is no good as it makes the site look like it is un-finished…I need the categories to show but when clicked on should say members only.(like it did before i switched over to your plugin – was using another one…but did not have levels) This is the selling point – showing people what they get…

    Do you have posts in your categories ?

    How have you protected the categories ?

    You can use the url gorups in such a way that the visitors can access category archives but not the actual posts just as I have done here : http://membership.wpdemo.in/category/uncategorized/

    Regular Expression – If any of your URLs have regular expressions in them, you must enable this

    option.If we enable Regular Expressions then as an example we could protect all posts in a category

    whilst still enabling access to the category archive page.

    So in the Page URLs we would enter:

    http://domain.com/category/.+

    The “.+” is known as a Regular Expression. In the above example, it will allow access to the

    category but then protect all the contents (single pages/posts/custom post type) of that category.

    This could be great if you’re building an online magazine and want your readers to see the archive

    page but restrict the goodness within to paying subscribers only.

    2 – If you click the equipment link it says – “the content you are trying to access is available to memebers only – THIS IS GOOD….why doesnt the “choose your machine” link say this – instead it says “Apologies, but no results were found for the requested archive. Perhaps searching will help find a related post.” This is no good as it makes the site look broken…the difference betwwen the 2 is the the first is a page and the second is a post….

    Regular expressions will fix it. Just give access to them for the category archive and restrict them from viewing posts.

    3 – as mentioned above – visitors cannot have access to the equipment page – when logged in as a free visitor the option of showing this page is not selected – why does the page show?

    Did you setup the rules for that. Perhaps you have not restricted the visitor level from viewing that page ?

    5 – where is a client meant to log in? i have tried creating alink on the register page but it will not display

    They will login using the normal WordPress login page.

    6 – what is the normal timeframe for an email to come back from support – please let me know so i can plan around this. As i mentioned the reason i joined is cause the support was meant to be second to none. I hope there has been a glitch in the system which caused a dely – and that this is not normal – I invested in you and decided to switch over as I need an affiliate solution – im dreading pluging that in now.

    The posts are replied using a feed. When there is a new post, we reply on that and wait for your response. When you respond, it comes in our feed. If you respond twice, it becomes a fresh feed and comes down in the stack. so If you make multiple posts that goes even at the bottom and that is why it gets delayed. I hope Tim also explained that to you on your recent post.

    I hope that helps. Please feel free to ask if you have more questions on the same.

    Cheers

    PC

  • Craig
    • Design Lord, Child of Thor

    Hi P,

    How do enable regular expressions? I have tried to edit the post url by adding /.+ but it wont save – can you give me step by step instructions here pls.

    As for the equipment page i have changed permissions – before i was using positive and left equipemnt un-selected but that did not work – so now i am using negative and selecting equipment and that works..

    When someone signs up for free they still cant see that page – but it says for members only – can i edit that message to say available to paying members.sorry

    so the only real problem i am having is regular expressions…I have also tried adding the URL groups in the negative filed for visitors but it say to tick the boxes of the URL – but there are none showing.

    You asked me about the categories – there are posts in my categories…

    The other problem which i discussed yesterday in the live chat is that the system is not sending out a welcome email….i was advised to change the settings to 1 day instead of 0 – i did get the welcome emails many hours later so i have changed it again to zero and nothing is coming through – how can we fix this so it send out the email when user registers.

    I need to get this all fixed so we can add the affiliate program in. Hope to hear from you soon – thanks for your help.

    BTW – sometimes (only sometimes) when i sign up for free account this is the message i get – and there are no options on the page…nothing to click…

    Please check the details of your subscription below and click on the relevant button to complete the subscription.

  • PC
    • WPMU DEV Initiate

    Hiya,

    How do enable regular expressions? I have tried to edit the post url by adding /.+ but it wont save – can you give me step by step instructions here pls.

    You do not have to enable them. You define them in the URL groups in Membership plugin and then you assign those URL groups to Access levels.

    When someone signs up for free they still cant see that page – but it says for members only – can i edit that message to say available to paying members.sorry

    This option is available when you define the rules. Just scroll down and you will see that option.

    The other problem which i discussed yesterday in the live chat is that the system is not sending out a welcome email….i was advised to change the settings to 1 day instead of 0 – i did get the welcome emails many hours later so i have changed it again to zero and nothing is coming through – how can we fix this so it send out the email when user registers.

    Can you please try with a normal registration and see if the emails are being sent properly ? Perhaps they are being delayed on the server. Did you check the server error logs to see if there is something ?

    To use a URL group feature, you need to create a URL groups and add the links or regular expressions to it. The process is mentioned in the Membership manual which I gave a link to above.

    Remember, the most important thing is rules. If you are putting something in positive rules, then selecting something will give access to that level.

    If you are using negative rules, then selecting something will restrict access.

    Cheers, PC

  • Craig
    • Design Lord, Child of Thor

    hi – i will look the url groups in the manual now – i fixed the email problem – i installed cofigure smtp…working well

    it seems that when i select something in positive it does NOT work – but in negative it works….for example – the accounts page does NOT show up for full members – but it shows up for free members…..

    i saw how you can edit the message for protected pages – but can i have a different message for different pages – for e.g. one say restricted to members – the other says restricted to PAYING members

    I have just opened another thread for affiliates problem….

  • PC
    • WPMU DEV Initiate

    hi – i will look the url groups in the manual now – i fixed the email problem – i installed cofigure smtp…working well

    That is great :slight_smile:

    it seems that when i select something in positive it does NOT work – but in negative it works….for example – the accounts page does NOT show up for full members – but it shows up for free members…..

    Did you look at the rules portion in the Manual ?

    it seems that when i select something in positive it does NOT work – but in negative it works….for example – the accounts page does NOT show up for full members – but it shows up for free members…..

    You can have it setup for different levels but not different pages

    Cheers

    PC

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.