membership blank loigin screen

When my customer user logs into the admin portion of the site, and clicks to go through to the dashboard, all they see/can access is a blank screen. I can not access the site using my admin credentials- same thing happens. Do you have any insight into why this is happening and how to resolve it. The site was handed over to the customer a few months ago and it worked fine then.

  • Vaughan

    hiya

    have they tried protecting the admin with it? or changed anything at all?

    you can temporarily gain access by renaming the plugin folder using FTP

    navigate to wp-content/plugins using your ftp client. then rename membership folder to membership-tmp

    that should get you in the dashboard. don't worry about settings, they'll be preserved.

    also whilst in ftp, can you check for an error_log in the same folder as your wp-config.php file, see if theres any errors listed.

    thanks.

  • gearbox

    Hi Vaughan,

    My customer can not confirm nor deny if he made changes to settings. I assume he or some one else did. As far as him protecting the dashboard or other parts of the site, I doubt it, but I don't know.

    The site has Membership installed, but the customer doesn't use it to block user levels from site content as it was designed to do. The site also uses BuddyPress and Events Manager Pro, along with several other plugins. The site worked fine when it was handed over to them, so I don't believe it to be a plugin conflict. Current WP version is 3.5.2

    I was able to temporarily gain access by renaming the membership folder. Thanks

    Following is the last line in the error log (I've also attached a text file with the last 4 days of errors):

    [Wed Aug 07 10:05:27 2013] [error] [client 64.8.132.253] PHP Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 30720 bytes) in /var/www/vhosts/learningforwardminnesota.org/httpdocs/wp-admin/includes/template.php on line 1613, referer: http://learningforwardminnesota.org/

    There are quite a few (approx 60) "PHP Fatal Error" errors, starting August 7th. The previous error was an August 5th "RSA server certificate CommonName (CN) `www.learningforwardminnesota.org' does NOT match server name.

    Is there a way to reset or remove the Membership user level settings or other Membership settings that may have gotten caused the problem- perhaps directly changing the database using PHPmyadmin or similar? As I mentioned, they really don't use the membership functionality yet, but it was integrated into the site when it was built with the intent that it would be used.

    Or do you have a strategy to fixing the problem without using a back up of the site to replace what is there right now. (I have weekly backups 3 weeks into the past).

    Thanks,
    Andy

  • Vaughan

    hiya

    sorry for the delay.

    the memory exhausted error can be fixed using

    memory_limit = 256M in a php.ini file

    or depending on the server setup, if htaccess can be used.

    see http://wordpress.shadowlantern.com/increasing-the-memory_limit/

    it does look like the issue is related to the server not having enough memory available for PHP. increasing the servers memory_limit to 256M should help, hopefully.

    hope this helps

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.