membership blocking images on pages

Good day,

I've got a new problem I can't figure out … Membership is blocking all images from view on pages for free users and paid subscribers. Oddly, the administrator (me:slight_smile: can see all images. Any ideas as to what is likely causing this problem?

The images affected are those I added directly to the page content in the WP editor. Other images (features, box sets) not in the page template are not affected. The images are all in .gif format.

The site is relatively new with a Membership setup from scratch. Just added the levels, subscriptions, and payment gateway (express-single payment) – of which appear in good order in test run. When I enabled the Membership plugin all the images disappeared for free and paid users.

Any ideas?

Thank you,

BDA4

  • Barry
    • DEV MAN’s Mascot

    If un-setting the masked download urls fixes things, then the issue looks like it is something to do with either your permalinks or htaccess file not handling rewrites correctly – but we’ll come to that after the first test Phil suggested.

  • BDA4
    • Design Lord, Child of Thor

    Phil and Barry,

    You are bang on. Unsetting (leaving field blank) the Masked download URL allows images to generate on pages for free users and subscribers.

    How can I get on the permalinks or htaccess file issue?

    I plan to offer pdf downloads to subscribers and will want to mask their location.

    Thanks,

    BDA4

  • BDA4
    • Design Lord, Child of Thor

    Hi Barry, thanks for helping,

    My htaccess file is below in a screenshot.

    As an aside, why would filezilla not show htaccess when connected to the server? Nothing else was omitted. I had to go to my server FTPclient to view the htaccess file …

    Thanks,

    BDA4

  • Barry
    • DEV MAN’s Mascot

    Ok, now – your "actual download url" looks wrong there.

    If you go into your Media panel and look at the details for an uploaded image what directory do you get?

    As an example(see image below) mine is:

    http://dev.site/wp-content/uploads/

    So my media protection settings look like the second image. If you can set your Actual Url to everything in the media path up to (but not including the numeric year and month details and without a trailing slash, then make up a new directory for the second part (see my example), and save those settings.

    Next step is to visit the permalinks page again and just re-save the current settings, or try selecting a different setting – save it, then reset to the current setting and save again to attempt to force the permalinks rewrite rules creation.

  • BDA4
    • Design Lord, Child of Thor

    It appears we got it working :slight_smile:

    I followed your instructions verbatim but the images still weren't generating. For some reason, however, when I take out the site domain name from the 'actual download url' field it works – even though the images' url download name in the Media settings includes the site domain name. The screenshots below explain best how it's working.

    Is this a fixed problem by Membership standards Barry? Or am I simply deferring problems …

  • Barry
    • DEV MAN’s Mascot

    No, all that is doing is not finding the URLs it’s after and so not actually protecting the content at all.

    If you put it back with the domain name – view the page so that the images don’t show and then view the source and find one of the images – what is the path to the image?

    If you put that in address directly in the address bar of your browser, what do you get?

  • BDA4
    • Design Lord, Child of Thor

    Hi Barry,

    I think I followed your instructions properly. After doing so the image shows … (Here's what I did: put the domain name back into "Actual Download URL"; viewed the page as a free user (still no images); signed back into admin to view html source for an image file path; logged out and viewed page as free user (still no images); pasted the html source for image in browser.)

    The basic path name for the html source code is the same as my "Actual Download Url" setting but still no images appear. Posted images of current settings below.

    Still no luck : /

  • Barry
    • DEV MAN’s Mascot

    Ok, that’s certainly a rewrite issue then – right, now for the technical bit :slight_smile:

    In your wp_options table there will be an entry with an option_name of “rewrite_rules”. The option_value for that record will be a mass of text and numbers – can you copy the content of that value field and place it in a text file, zip it up and upload it to here – I can then run a check on it to see if the relevant rewrites have been added to it (i suspect not, but it’s best to check these things out) or are conflicting with something else.

  • BDA4
    • Design Lord, Child of Thor

    Hi Barry, that was a bit technical :slight_smile:

    I believe my "wp_options" table is named "wp_ex3547_options". All my tables had the '_ex3547_' added to them. Posted a screenshot of a "rewrite_rules" for the file, and an attachment of the requested option_value field in text format …

    Many thanks for your continued help!

  • BDA4
    • Design Lord, Child of Thor

    Sorry Barry – I’m not sure what you mean/want me to do regarding payment gateway return? ((I have paypal express single payments activated and I’ve set my gateway to return customers to (http://freshnurse.ca/welcome/) after payment. Is this what you want me to look at?))

    I’ve sent my acct details by email – would love for you to have a look.

  • Barry
    • DEV MAN’s Mascot

    BDA just put your domain in the place of domain.com in the url i gave and see what it says / does as that’s the IPN notification url for the plugin and so needs to work as well – and also uses rewrites.

    Actually – don’t use this one instead (for the single payments gateway):

    http://domain.com/paymentreturn/paypalsolo

    I’ve sent my acct details by email – would love for you to have a look.

    Ok, will do when the guys get it over to me :slight_smile: I’ll let you know what I find.

  • BDA4
    • Design Lord, Child of Thor

    My IPN settings haven’t been set yet – mainly because I wasn’t sure what the IPN url was. Now I know :slight_smile: I’ve just set the Paypal url field with the above said IPN url.

    After setting the paypal.com IPN url field I put the said http://domain.ca/paymentreturn/paypalsolo and I was sent to a broken link page eg. “oops! this link appears to be broken”.

    I think I’m not being useful here …

  • BDA4
    • Design Lord, Child of Thor

    Thanks Phil,

    We’d definitely like to figure this one out – right now our members can see the download url which isn’t cool. Let me know if you need me to forward my account information again … would love Barry to have a look :slight_smile:

    ~BDA4

  • Barry
    • DEV MAN’s Mascot

    (this may be random but interesting, if i put in the url “… /paymentreturn/paypalexpress/ ‘ instead of “… /paymentreturn/paypalsolo/” I am sent to my blog page.)

    If you haven’t got that gateway activated then it doesn’t respond to IPN notifications so that’s normal.

    Got a membership update coming with some fixes and we’ll see if that solves a few problems

  • SRCenter
    • Flash Drive

    Hi guys I have WP 3.3.1 w/ Membership 3-RC-1 installed…

    My pictures disappear after install of the Membership plugin…

    I have deactivated the Membership plugin and the images come right back.

    We have tried to remove the Masked download URL and that worked, but we want to use the mask download feature as we have a pdf we wish to give away and don’t want to expose our URL.

    Here’s what our .htaccess file looks like…

    # BEGIN WordPress

    <IfModule mod_rewrite.c>

    RewriteEngine On

    RewriteBase /beta/

    RewriteRule ^index.php$ – [L]

    RewriteCond %{REQUEST_FILENAME} !-f

    RewriteCond %{REQUEST_FILENAME} !-d

    RewriteRule . /beta/index.php [L]

    </IfModule>

    # END WordPress

    Anyway ideas, we appreciate your help!

    Thx guys

  • aecnu
    • WP Unicorn

    Greetings SRCenter,

    Welcome to WPMU Dev!

    Fortunately I was in the back of the ticket system where I came across your addition to a ticket that was closed four months ago being monitored by a technician that is no longer with us which was referencing a version of Membership that at the time did not exist.

    We are not ignoring you, just nobody new this ticket even existed.

    Please copy and paste your original ticket into a new ticket of your own and I think you will find that technicians will be all over it :slight_smile:

    Sincerely, Joe

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.