Membership change member status from active to pending

Need some Membership 2 help. When manually adding a member, I'm having a bit of trouble with trying to change a member status from active to pending (activate on next payment) it keeps cycling back to active when I hit the save button.

Basically what we're trying to do is have a user added manually by a staff member then set the membership to pending then have the end user login and pay for their membership. We have several different types of courses that we are offering but our boss only wants to have the end user see their specific course that they signed up for instead of a membership list that shows all of the memberships.

    Nithin

    Hello Howard Fine,

    I could notice the same, I'm checking this with the developer to see whether this is the default behavior with "One Payment for Permanent access" Payment option. Please do note that developers work round the clock with many critical issues, and hence have a slow response time. Either myself, or the developer will keep you posted asap.

    Kind Regards,
    Nithin

    Panos

    Hi Howard!

    I think it is related to the fact that the default gateway is set to "None (admin)". The pending status is not allowed with the admin gateway.

    Paid subscription are meant to be created by user from front. As a workaround, I have a mu-plugin that adds the gateway option in the member's subscription page. It has to be used with caution though. please read the IMPORTANT note at the end of this post. You can download it from here:
    https://gist.github.com/panoslyrakis/e5d5daf1d8fb85f7c3995a2bd7570c79
    and upload it to your wp-content/mu-plugins folder (if that folder doesn't exist you can simply create it)

    Once you have uploaded this file you should be able to see a gateway option in the subscriptions page:
    [image pos="0"]

    After selecting a gateway to something other than admin you should be able to change the status to pending.

    IMPORTANT
    If you set the status to Pending please keep in mind not to set the payment gateway to "None (Admin)". Doing this can remove the subscription. I would suggest to remove the mu-plugin after you update the subscriptions you need. In the meanwhile I'll try set a way to select the payment gateway when manually creating the subscription from admin. Please confirm you have understood the dangers of using this.

    Thanks!