Membership, controlling search page

I am having trouble allowing the search page to work for members. When I set up URL groups for search my whole site goes kaflooey. Is there a trick to using url groups to allow search page access for members? I have tried a few regular expressions, and have tried strip query on and off, but so far have had no luck.

A couple things to note: I am successfully using an URL group to control access to a custom post type by making a negative rule and using a regex to block all posts beyond a certain directory.

Search works for a couple of random words like blog or hello, but other single words that should also come up dont. And, all two letter words fail to find anything.

Under an admin account search works perfectly in all cases.

  • Mason
    • DEV MAN’s Sidekick

    Hiya coloradocolin,

    That is really odd.

    Search works for a couple of random words like blog or hello, but other single words that should also come up dont. And, all two letter words fail to find anything.

    That's odd. The URL Groups should work regardless. Are you simply using the WordPress built-in search for this or something else? I'm gonna see if I can recreate this on my install and ask the developer to drop in with thoughts as well.

    Thanks for the additional info.

  • coloradocolin
    • Design Lord, Child of Thor

    Search works for a couple of random words like blog or hello, but other single words that should also come up dont. And, all two letter words fail to find anything.

    The above is without a URL group in place for a logged in "member". Admins search works fine and the search box is not present for nonmembers.

    URL groups for search causes every page in the site to return a 404 including the home page. Its quite possible it is my regex, as I am not an expert in that.

    Here are some examples I have tried:

    http://mysite.com/?=.*
    http://mysite.com/?=*

    I am using the standard wordpress search function.

  • coloradocolin
    • Design Lord, Child of Thor

    Every potential combination I have tried results in the member being locked out of the site completely. I tried just having mysite.com/?= with regular expression set to yes and no and strip query set to yes and no, and all combinations give the same result = user locked out of the site.

    I dont really understand what the issue is, as search works out of the box on my defaut test install (basic membership set up with twenty ten theme), without url groups or anything.

  • coloradocolin
    • Design Lord, Child of Thor

    Yeah, I would love to get some help on this. I started another thread that has also been overlooked. I'll take any advice at all. Just tell me where to look, how search intereacts with plugin, whatever. I need search to function, and I also need a functional membership plugin. How can I get them to coexist properly? I have tried everything I can think of including reinstalling the plugin and reconfiguring everything from the ground up. I'd just buy a different plugin if I could afford it, but I have blown the whole budget trying to fix this one.

  • James Farmer
    • CEO (of WPMU DEV, honest)

    Apologies for us overlooking this thread... I'm hoping we did so because it was resolved in the other thread.

    If it wasn't resolved, or you have any more questions related to this thread please feel free to post them below and tick the 'Mark as Not Resolved (re-open)' box below the post area (or else we'll miss it!)

    Otherwise, thanks for using the forums, and for being a member of WPMU DEV, it's a pleasure to help you out and we look forward to being of assistance in the future.

    Cheers, James

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.