Membership coupon issues

I'm loving the membership plugin, but I'm having serious trouble with the coupons. First, after adding a new coupon it doesn't show up in the list on the Edit Coupons screen. In fact, none of my coupons show up there even though they are functioning on the site.

The other issue is that it doesn't limit the coupon's use to the subscription I specify.

Please help :slight_smile:

Thanks

  • aecnu
    • WP Unicorn

    Greetings jao,

    Welcome to WPMU Dev!

    Sorry to see that you are having an issue with the Membership plugin.

    Lets dig right in.

    Can you please logged into the admin dashboard go to --> Membership --> Options --> Advanced tab and choose to verify tables and then to run a repair tables and test your coupon addition again.

    Please advise how our test goes.

    Cheers, Joe

  • jao
    • New Recruit

    I was able to fix one of the issues with a snippet for membershipadmin.php that I found looking through the comments.

    The other problem still remains with the coupon not sticking to only the subscription plan that I selected in the drop down.

  • jao
    • New Recruit

    I was able to fix one of the issues with a snippet for membershipadmin.php that I found looking through the comments.

    The other problem still remains with the coupon not sticking to only the subscription plan that I selected in the drop down.

  • aecnu
    • WP Unicorn

    Greetings jao,

    Thank you for the additional input which is absolutely appreciated.

    Happy to hear that you have managed your

    The other problem still remains with the coupon not sticking to only the subscription plan that I selected in the drop down.

    I checked on the coupon issue and cannot find where it applies to any specific subscription. From what I can tell they are or they are not usable.

    Please advise as to what or where I am missing this.

    Cheers, Joe

  • DustinTuccillo
    • WPMU DEV Initiate

    I am having the same issue. When i fill out the add coupon it doesn't show up in the list. It does show up in the DB tables. I add the value to attach it to a specific subscription plan, which it reads in the DB tables... BUT it works on every subscription plan regardless. Please help. I have repaired tables etc...

  • aecnu
    • WP Unicorn

    Greetings jao and dustinmcshane,

    We have not heard back from you as to the status of this issue.

    If you are still having an issue please let us know so that we may try to get you fixed up as soon as possible by choosing to check mark this ticket as unresolved below and posting any new errors or symptoms you are noticing.

    This action will also bring your ticket up front back in plain view again within the ticket system.

    Thank you for being a WPMU DEV Community Member!

    Cheers, Joe

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.