Membership Gateway 404 issue!

Hello,

The problem is that on any gateway I try to add details to and 'save' it doesn't work. I can activate any of them, currently all I want is 'PayPal Express - with Single Payments' to work. So I can activate it correctly, but when I enter any test or real PayPal address and try either live or test site and hit save I get:

Forbidden
You don't have permission to access /wp-admin/admin.php on this server.
Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

My test site is at: http://www.menorahlight.com/
Running Wordpress 3.3.1 + Membership 3.0
Fresh installation default theme being used: Twenty Ten 1.3 by the WordPress team
I'm more then happy to supply login details.

- I've tried multiple fresh installations, both on full urls, sub domain urls.
- I've tried upgrading from previous membership versions, tried full membership 3.0 installion.
- Tried giving all files 777 permissions.
- Only have 1 account which is 'admin'
- Haven't changed anything since installation except installing membership plug-in (http://www.menorahlight.com/

I've been hitting my head against the wall for DAYS now and searching forums etc, so thought I would try here and 'Hope' it doesn't take weeks to get a response :slight_smile:

Looking forward to feedback :slight_smile: Cheers.

  • Timothy Bowers

    Hey toggleway.

    As well as permissions it could also be an ownership issue, can you ensure all files are first 644 and folders 755 except those which need to be 777. Then double check that all of them are owned by the account and not root or something else.

    Is this share hosting?
    What is the current environment?
    What has your host said about these permission issues?

    I suppose you could try a fresh batch of WP files as well.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

    Thats because it can't find the error document, the issue is the permission denied error.

    It might be worth recursively setting permissions for files and folders and chown (ownership) them as well.

    Let us know how you go.

    Take care.

  • toggleway

    Hello Timothy,

    I think your right on the money, as I just tested on localhost and it works fine and then another online server I have and it works fine.

    I'm using a Reseller Web Hosting account (not sure if shared, though possibily - http://www.digitalpacific.com.au/hosting/partner-programs/reseller-programs/ )

    I've tried reinstalling in many ways :slight_smile:

    The server details are:
    Apache version 2.2.22
    PHP version 5.2.17
    MySQL version 5.1.61-log
    Architecture x86_64
    Operating system linux
    Perl version 5.8.8

    All of my folders are 755 and all my files are 644. I quote you: "except those which need to be 777." Where do I find those that need to be 777? I've tried wp-content 777, wp-admin 777 just to see if it would fix it, it didn't.

    Then I tried in my 'what was once empty' .htaccess file (located in the root folder):
    <IfModule mod_security.c>
    <Files admin.php>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </Files>
    </IfModule>

    I've ran out of ideas.. why would it work on a completely different hosting company when the folder and file permissions appear to be the same?

    Kind Regards,
    Daniel

  • Timothy Bowers

    All of my folders are 755 and all my files are 644. I quote you: "except those which need to be 777." Where do I find those that need to be 777? I've tried wp-content 777, wp-admin 777 just to see if it would fix it, it didn't.

    Usually they would be folders where you might upload content to or change from WordPress.

    Some more information here:

    http://codex.wordpress.org/Changing_File_Permissions

    Some plugins require the /wp-content/ folder be made writeable, but in such cases they will let you know during installation. In some cases, this may require assigning 755 permissions. The same is true for /wp-content/cache/ and maybe /wp-content/uploads/ (if you're using MultiSite you may also need to do this for /wp-content/blogs.dir/)

    I've ran out of ideas.. why would it work on a completely different hosting company when the folder and file permissions appear to be the same?

    Different setups, different configs and different requirements.

    Have you asked your hosting provider for some assistance? Just wondering what they have to say about it?

    You've tested it in other environments and its all good, so it must be something with them and their hosting.

    Would be worth speaking with em about it.

    Please do let us know how you get on.

    Take care.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.