Membership has ended emails will not stop sending.

Hi. This is actually a question pertaining to the live npbrc.com website - but I have been working on the staging site that I listed above to try to figure out what is wrong. There is ONE member (me) who has a 30 day membership and it ended about a month ago. I have since gotten countless emails saying that the membership has ended with no way to unsubscribe. I'm worried that when I make this live for members - they will also get endless emails. They also come from "wordpress" and I don't want that either. How can I customize these messages or get them to be sent only once or twice? I can forward you one, or many, of them if you want...

  • Tyler Postle
    • CGO

    Hey Jessica,

    Hope you're doing well today!

    You can change the default "from" email in WordPress with this plugin: https://en-ca.wordpress.org/plugins/wp-change-default-email/

    So it keeps sending you "membership ended" emails for the same membership? Or do you have the "send copy to admin" option checked for the "Subscription - After Expired" email - if you do, then it will send you a copy of every members "expired" email. I've taken a screenshot of the setting to illustrate.

    If that isn't the issue then do you mind granting support access to your site? Then we can have a closer look :slight_smile:

    You can grant support access via WPMU DEV > Support > Support Access > Grant Access.

    All the best,
    Tyler

  • Jessica
    • Site Builder, Child of Zeus

    Hi! Thanks for the quick reply! I installed that plugin on my dev server.

    I checked the settings and Its definitely just this one user - and it's just coming to me over and over.
    But sorry - I see no screenshot attached here.

    I will grant you access to the live site where this seems to be coming from. Thanks!

  • Tyler Postle
    • CGO

    Hey Jessica,

    Sorry about that, I must of forgot to attach it - happens at least once a day :slight_frown: lol I've attached it for this time!

    I logged in, but I see you have Membership 2 deactivated on your live site. It's still sending the emails while deactivated or you deactivated it to stop it from sending emails? I wasn't sure whether or not I should activate it to have a look since it's your live site. If it's okay to temporarily activate it just let me know then I'll go in for another look.

    Cheers,
    Tyler

  • luke
    • Flash Drive

    Hi,

    I too am having this problem, I do not have the "send a copy" setting on & am receiving am email once a day saying my account has expired.

    Is there another setting for this frequency. Obviously turning off the expired email would stop it but isn't ideal as one email would be great for users but not one a day

    Thanks,
    Luke

  • Tyler Postle
    • CGO

    Hey Luke,

    There isn't an option for setting the frequency of those emails, you shouldn't be receiving them at all if you don't have that send to admin option selected. Can you create a new ticket as it appears the issue may be caused by something else so we'll need to investigate further: https://premium.wpmudev.org/forums/#question

    If you could grant support access as well that would be helpful.

    You can grant support access via WPMU DEV > Support > Grant Support Access.

    http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    We have staff watching for new tickets 24/7 so you won't need to wait long for a reply :slight_smile:

    Cheers,
    Tyler

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.