Membership. I don't see a payment link

When I try to add a member, and ask that the membership be activated upon receipt of payment, I don't see a payment link in the email sent.
Also, it's being flagged as spam and when you click on the invoice link it's redirect to 404 error code.

  • Paul

    You didn't find the invoice because it was deleted, as it is incorrect.

    Here are the steps taken, my expected outcome, and what actually is seen/generated:
    1. Click on "add member". Expectations, create a new member, add a membership, and send an invoice with a payment link in the email.
    a. clicked on add member, and then chose an existing wordpress user.
    b. the next option is to choose a membership and check a checkbox for "create invoice"
    c. the next option is to manage the start and enddate of the membership.
    d. apparently I shouldn't press "create invoice" in the previous screen, because it sends a notice that the membership is active, paid, and started right away.

    basically, the user is created, but the subscription becomes active immediately.

    Also, now when an admin user views the invoice for the "managed subscription", it now also shows the other "active" membership.

    So far, the new user is NOT able to access anything, and has NOT received anything concerning the modified, "managed" subscription.

    I have attached several screenshots. At this point, I am not going to troubleshoot this further. if you wish login to a dev site, to troubleshoot these issues, I can provide it. However I must move on and use another solution, to get this site into production mode. If you can solve these multiple issues, you can message me, and perhaps on another site, I will use this product. For now though, I regard it as a non-working plugin, with huge bugs.

    Paul



    [image pos="2"]




    [image pos="6"]

  • Ash

    Hello Paul

    I am sorry for the delay. Thank you so much for the explanation. I have talked to the developer about your issue and he wants to take a look. So, I have sent your issue to our second level support team. Please note that, they deal with more complex issues, so there might be little delay. We appreciate your patience on this.

    Also, would you please send me your admin login and cPanel details so that I can pass to the developer?

    You can send me privately in the following format:
    1. Please go to https://premium.wpmudev.org/contact/#i-have-a-different-question
    2. Select "I have a different question" if not selected
    3. In subject line put "Attn-Ash" (this will ensure that the email is assigned to me)
    4. Provide the wanted details.
    5. Add the thread link in the message so that I can track.

    Have a nice day!

    Cheers,
    Ash

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.