Membership - Levels is a life membership possible?

I have just set up my first membership site. (It's under a maintenance screen so I can't give you the URL). I'm not using multisite or BuddyPress. I have set a free level and a premium level and and have made shortcodes - but I don't think I have the shortcodes working properly as the content I have wrapped in 'free' does not show. The message that I set for non-members repeats several times which is a bit odd.

I would like to also have a life member level of membership that I can give certain indivuals - not through the paid subscription screen. I cannot figure out how to do that.

  • Barry

    I have set a free level and a premium level and and have made shortcodes - but I don't think I have the shortcodes working properly as the content I have wrapped in 'free' does not show. The message that I set for non-members repeats several times which is a bit odd.

    Can you give us more details of your setup? Screenshots of the levels / subscriptions etc.

    I would like to also have a life member level of membership that I can give certain indivuals - not through the paid subscription screen. I cannot figure out how to do that.

    Go to the Edit Members page, hover your mouse over the Levels column next to the user you want to update. Click Add and then add the level you want them on.

  • Alirat

    Thanks Barry. I will work on the levels thing adding a bit at a time. My first attempt had me not being able to see any content. I am thinking that perhaps the less rules the better? Ie all content should default to being visible except when wrapped in shortcode tags? I don't need to hide posts or pages, just some content within. Am I right in thinking that under the Levels setup if you don't drag a rule into either positive or negative it will default to being visible?

  • Barry

    Am I right in thinking that under the Levels setup if you don't drag a rule into either positive or negative it will default to being visible?

    Yes, if you don't specify anything for a rule then it will work as if membership wasn't installed / running. Unless you have specified an option in the membership options to set some form of operation to be the default. E.g. if you protect More tags by default, then you will need to drag the more tag rule to the positive area of a level in order for a member to see them.

  • Alirat

    Hi Barry
    I started from scratch again and what I have now is that the actual shortcode shows up for everybody/non-members. Ie nothing is protected Here are my settings:
    Options:
    Stranger settings: use membership level 'free'
    User registrations - use subscription 'none'
    enable incomplete signup 'y'
    Registration page - 'subscribe' (page i created)
    Account page - 'account' (page I created)
    protected content page - 'no access' (page i created)
    Override 404 'No'
    Shortcode protected content
    shortcodes
    free
    premium

    shortcode visibility default 'No- Shortcodes are not visible by default'
    No access message (an html link to the subscribe page)

    Downloads media protection (doesnt apply to this site)
    Actual downnload URL http://alirat.net/
    Masked download URL http://alirat.net/downloads/
    protected groups (non doesn't apply - no BuddyPress)
    More tag default
    Show content after more tag 'Yes- more tag content is visible'
    Payments currency NZD
    Membership Renewal 30 days
    Membership upgrades 1 day
    BuddyPress protected content message
    nothing in here as not applicable
    Simple Invite codes
    nothing in here as not applicable

    On the Edit Levels page I have two levels Free and Premium
    In the Free one I have added 'shortcodes' to the negative with 'premium' ticked
    On the Premium I have added 'shortcodes' to the positive with 'premium' ticked.

    This is the simplest of set-ups but it is not working yet.

    I have taken off the maintenance screen to enable someone to help. the URL is http://www.alirat.net/

    I am up to date with all versions of everything and am using permalink settings /%post_id%/%postname%/ (if that has anything to do with anything...)

    Thanks for helping it is appreciated.

  • Mason

    Hiya,

    Are you using the latest beta on the forums or the stable version (2.0.7)?

    I took a look a the site and the shortcodes aren't showing up for me - in fact its' just a message forcing me to signup when I try to read any full post. Easiest way to test 'guest' settings is to use a separate browser for that.

    When you use a completely different browser do you still have an issue? Let us know.

    Thanks!

  • Alirat

    It is 2.0.7. This morning when I looked I can see the same as you, all content is blocked, rather than open as it was yesterday. To me this is the same problem as I had shortcodes on the pages showing some content and hiding other content, just as the instructions showed. I will try in different browsers but I'm not feeling hopeful at this point. The subscribe process doesn't work either, step 2 doesn't allow you to make a choice (I have it set for $1 if anyone wants to give it a try) . Beginning to think the plug in is a little unfinished and have been trying to find sites that actually use it / or recommendations for the plugin but haven't turned up anything yet.

    Edited to say the subscribe does work - I didn't have the gateway activated.

  • Barry

    he subscribe process doesn't work either, step 2 doesn't allow you to make a choice (I have it set for $1 if anyone wants to give it a try) .

    Do you have your gateways set up and activated, and the subscriptions set to public and active?

    Beginning to think the plug in is a little unfinished and have been trying to find sites that actually use it / or recommendations for the plugin but haven't turned up anything yet.

    It's just complicated to set up, but once you have it set for your needs you can pretty much leave it alone after that and it will handle the protection itself. http://staypress.com uses it and is live and functioning very well.

    Actual downnload URL

    This is wrong, it should the the url of your actual files. Have you edited this or is that the setting it was originally set at.

    In the Free one I have added 'shortcodes' to the negative with 'premium' ticked

    If you are protecting the shortcodes by default, then you don't need this rule in there.

  • Alirat

    I have the gateway set up and active, I have the subscription set up and active (just one - premium). I have made categories of free and premium, but Just want to use shortcodes if that is possible. So at the moment post called 'video' has no shortcode but is displaying protected. It does have the 'premium' category but I have not invoked that rule. Page "Hello World" has 'free' shortcode and 'premium' shortcode but all the content is protected. It appears as if all Posts are protected by default. is there a setting somewhere for that?

  • Barry

    I haven't got any files to download, so I don't need anything in there.

    You may get unpredictable behaviour if it's not set correctly as it is used for images within posts as well (which are also considered downloads).

    I have made categories of free and premium, but Just want to use shortcodes if that is possible.

    Not sure what you mean here. Shortcodes only protect the part of the content embedded within them - categories protect the whole post - so they are for different things.

    It appears as if all Posts are protected by default. is there a setting somewhere for that?

    It's the stranger settings that sets the default - so it'll be what's in that level.

  • Alirat

    Re the download files - what should the settings be then? The system set the first address Actual Download settings - I can't think what the masked setting should be if I'm not offering file downloads. The same as the Actual I guess.

    Ok just to ease confusion I have set both posts to uncategorised. I simply want part of the post to be free (public) and part of the post to be protected (members only) . But what is happening is that the content of both posts is protected - the Video post has no shortcode and the Hello World post looks like this:

    [free] Welcome to WordPress. [/free]

    [premium]This is your first post. Edit or delete it, then start blogging![/premium]

    This is how it is explained in the instructions.

    The stranger setting is on 'Free' - which in the options now has no rules applied to it at all.

  • Barry

    You don't need a shortcode for the free part as you want everyone to see that content no?
    Try putting the permium shortcodes on their own lines and test.

    Re the download files - what should the settings be then? The system set the first address Actual Download settings - I can't think what the masked setting should be if I'm not offering file downloads. The same as the Actual I guess.

    When you upload a file what is the path it gets uploaded to? You should the masked download url blank if you are not using protected downloads.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.