membership not sending emails... enewsletter plugins works

membership not sending emails... enewsletter plugins works through smtp, for test... but the membership plugin wont sent communication neither will the automessage pluggin...

  • roger_lopez

    I tried other smtp plugins and they did not work... I used the same settings and loggins from newsletter plugins... the ones that gave me some errors gave me this...
    Test Message Sent
    The result was:
    bool(false)
    The full debugging output is shown below:
    object(PHPMailer)#3448 (69) {
    ["Version"]=>
    string(5) "5.2.7"
    ["Priority"]=>
    int(3)
    ["CharSet"]=>
    string(5) "UTF-8"
    ["ContentType"]=>
    string(21) "multipart/alternative"
    ["Encoding"]=>
    string(4) "8bit"
    ["ErrorInfo"]=>
    string(18) "Message body empty"
    ["From"]=>
    string(25) "newsletter@digitalsmb.com"
    ["FromName"]=>
    string(55) "DigitalSMB - Small Business Digital Marketing Community"
    ["Sender"]=>
    string(0) ""
    ["ReturnPath"]=>
    string(0) ""
    ["Subject"]=>
    string(52) "WP Mail SMTP: Test mail to roger_lopez77@hotmail.com"
    ["Body"]=>
    string(0) ""
    ["AltBody"]=>
    string(68) "This is a test email generated by the WP Mail SMTP WordPress plugin."
    ["Ical"]=>
    string(0) ""
    ["MIMEBody":protected]=>
    string(0) ""
    ["MIMEHeader":protected]=>
    string(0) ""
    ["mailHeader":protected]=>
    string(0) ""
    ["WordWrap"]=>
    int(0)
    ["Mailer"]=>
    string(4) "smtp"
    ["Sendmail"]=>
    string(18) "/usr/sbin/sendmail"
    ["UseSendmailOptions"]=>
    bool(true)
    ["PluginDir"]=>
    string(0) ""
    ["ConfirmReadingTo"]=>
    string(0) ""
    ["Hostname"]=>
    string(14) "digitalsmb.com"
    ["MessageID"]=>
    string(0) ""
    ["MessageDate"]=>
    string(0) ""
    ["Host"]=>
    string(14) "smtp.1and1.com"
    ["Port"]=>
    string(2) "25"
    ["Helo"]=>
    string(0) ""
    ["SMTPSecure"]=>
    string(0) ""
    ["SMTPAuth"]=>
    bool(true)
    ["Username"]=>
    string(25) "newsletter@digitalsmb.com"
    ["Password"]=>
    string(7) "bugsy13"
    ["AuthType"]=>
    string(0) ""
    ["Realm"]=>
    string(0) ""
    ["Workstation"]=>
    string(0) ""
    ["Timeout"]=>
    int(10)
    ["SMTPDebug"]=>
    bool(true)
    ["Debugoutput"]=>
    string(4) "echo"
    ["SMTPKeepAlive"]=>
    bool(false)
    ["SingleTo"]=>
    bool(false)
    ["SingleToArray"]=>
    array(0) {
    }
    ["do_verp"]=>
    bool(false)
    ["AllowEmpty"]=>
    bool(false)
    ["LE"]=>
    string(1) "
    "
    ["DKIM_selector"]=>
    string(0) ""
    ["DKIM_identity"]=>
    string(0) ""
    ["DKIM_passphrase"]=>
    string(0) ""
    ["DKIM_domain"]=>
    string(0) ""
    ["DKIM_private"]=>
    string(0) ""
    ["action_function"]=>
    string(0) ""
    ["XMailer"]=>
    string(0) ""
    ["smtp":protected]=>
    NULL
    ["to":protected]=>
    array(1) {
    [0]=>
    array(2) {
    [0]=>
    string(25) "roger_lopez77@hotmail.com"
    [1]=>
    string(0) ""
    }
    }
    ["cc":protected]=>
    array(0) {
    }
    ["bcc":protected]=>
    array(0) {
    }
    ["ReplyTo":protected]=>
    array(0) {
    }
    ["all_recipients":protected]=>
    array(1) {
    ["roger_lopez77@hotmail.com"]=>
    bool(true)
    }
    ["attachment":protected]=>
    array(0) {
    }
    ["CustomHeader":protected]=>
    array(0) {
    }
    ["lastMessageID":protected]=>
    string(0) ""
    ["message_type":protected]=>
    string(3) "alt"
    ["boundary":protected]=>
    array(0) {
    }
    ["language":protected]=>
    array(18) {
    ["authenticate"]=>
    string(35) "SMTP Error: Could not authenticate."
    ["connect_host"]=>
    string(43) "SMTP Error: Could not connect to SMTP host."
    ["data_not_accepted"]=>
    string(30) "SMTP Error: data not accepted."
    ["empty_message"]=>
    string(18) "Message body empty"
    ["encoding"]=>
    string(18) "Unknown encoding: "
    ["execute"]=>
    string(19) "Could not execute: "
    ["file_access"]=>
    string(23) "Could not access file: "
    ["file_open"]=>
    string(33) "File Error: Could not open file: "
    ["from_failed"]=>
    string(35) "The following From address failed: "
    ["instantiate"]=>
    string(36) "Could not instantiate mail function."
    ["invalid_address"]=>
    string(15) "Invalid address"
    ["mailer_not_supported"]=>
    string(25) " mailer is not supported."
    ["provide_address"]=>
    string(54) "You must provide at least one recipient email address."
    ["recipients_failed"]=>
    string(45) "SMTP Error: The following recipients failed: "
    ["signing"]=>
    string(15) "Signing Error: "
    ["smtp_connect_failed"]=>
    string(22) "SMTP connect() failed."
    ["smtp_error"]=>
    string(19) "SMTP server error: "
    ["variable_set"]=>
    string(30) "Cannot set or reset variable: "
    }
    ["error_count":protected]=>
    int(2)
    ["sign_cert_file":protected]=>
    string(0) ""
    ["sign_key_file":protected]=>
    string(0) ""
    ["sign_key_pass":protected]=>
    string(0) ""
    ["exceptions":protected]=>
    bool(true)
    }

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.