Membership Plug-in — Admin Created Users Not Working

We are having problems with the membership plug-in on our site. It works well except for users that we create via ADMIN and not our paypal gateway. If a user subscribes and pays through paypal, they are allowed to access our restricted pages correctly. When we create a user through the WP admin dashboard and assign it the “all-access” access level they are getting our restricted page/stranger/visitor page–or whatever its called. I’ve tried going through all the options and can’t seem to get a user created through the admin to work unless they are an administrator no matter the subscription or access-level I assign. If you could let us know what could be going on here it would be much appreciated. Let me know if I need to clarify anything or if you have questions

  • JudiKnight
    • WPMU DEV Initiate

    everything works fine if the user subscribes and pays for the membership, then they have access. Sometimes, I want to give the course away at no charge. I then add the person as a user through the regular WP user-registration as a subscriber and then I assign them to a membership level. Seems like this should work but when they log in they do not have access to the protected information. Am I doing this wrong?

  • aecnu
    • WP Unicorn

    Greetings JudiKnight,

    Thank you for the additional clarification but to find out if indeed you are doing this right or not I need to know what gateway the admin added users are assigned as I had kindly inquired about in my previous post.

    Please advise and Happy New Year!

    Cheers, Joe

  • MScott821
    • Site Builder, Child of Zeus

    Judi – if you add them, they might get left at a status of “Inactive”, and likely the Gateway for that user will show “admin”.

    In the All Members screen of the dash – take a look at the users you have created and see if this is true.

    If so, adjust each user created this way such that they show Active and also have the same gateway as your paying users.

    Moving forward, once they have the kinks worked out with the coupons, it will probably be a better solution to give them a 100% discount coupon and have them create their own registration. (guessing anyway)

  • JudiKnight
    • WPMU DEV Initiate

    @aecnu — The members that are not working are under the "admin" gateway, but even when I manually change this to "paypalsolo" which all the paying customers use–it still doesn't work.

    @mscott821 — Thanks for your response. The members were all set to "Active" but aren't working. I also tried to change the gateway from "admin" to "paypalsolo" and that didn't work. I went to try and set up a 100% off coupon so I could just set up my free users with that, but (as you see in the screenshot) The coupon option is not in my WP membership menu options. Am I missing something? When I look online at screenshots of others I see coupons as an option under membership in the WP dashboard.

    Anybody have any idea what's going on here? Thanks!

  • JudiKnight
    • WPMU DEV Initiate

    Any Ideas Anyone? I’ve tried installing the membership plugin on a test site and the Coupons tab is showing up for that. I’m thinking about deactivating/uninstalling the membership plugin and reinstalling it to try and get it to work. If I did this, would I lose all my current membership settings and members?

    Thanks

  • MScott821
    • Site Builder, Child of Zeus

    Judi – don’t know for sure, but my guess – could be wrong – would be that would not lose the members and maybe not the settings. Members records should be written to the mySQL database attached to your wordpress install, so I would think if you uninstall and re-install they would still be there…

    One of the WPMU guys should really confirm though.

    That said, uninstalling and re-installing is probably not really the fix for the coupons not showing.

    Does “Coupons” appear in the WP admin dash navbar on the left under Membership?

    Has any of your site settings xml/php been changed?

  • aecnu
    • WP Unicorn

    Greetings JudiKnight,

    Thank you for the additional input and the screen shots which are absolutely appreciated.

    The first thing we should do here is check that all the database tables are indeed intact.

    Logged into the admin dashboard go to Membership –> Options –> Advanced tab –> click Verify Membership Tables and get the results –> and then Repair Membership Tables

    In the same area but on the General tab check mark Enable incomplete signup accounts

    Next would be to set the admin added users to the applicable gateway as you have mentioned above.

    Are you using a caching plugin of any kind?

    Are you using two browsers, one for developing and one for testing and emptying the testing browser cache and deleting the cookies in between tests?

    Please advise.

    Cheers, Joe

  • MScott821
    • Site Builder, Child of Zeus

    Joe –

    What is the significance of whether caching is used?

    In most situations, caching is critical for acceptable performance.

    If caching can have adverse affects, are there some (published) guidelines about settings in the caching software so that everything is happy?

  • aecnu
    • WP Unicorn

    Greetings JudiKnight,

    We have not heard back from you as to the status of this issue.

    If you are still having an issue please let us know so that we may try to get you fixed up as soon as possible by choosing to check mark this ticket as unresolved below and posting any new errors or symptoms you are noticing.

    This action will also bring your ticket up front back in plain view again within the ticket system.

    Thank you for being a WPMU DEV Community Member!

    Cheers, Joe

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.