Membership Plug-In Crashed My Site!!!!!

I installed the WPMU Dashboard and activated the Membership plug-in. Now, I keep getting "500 internal server" error messages whenever I attempt to access my site.

I changed my plug-ins folder to DEACTIVATEplugins via FTP, and even deleted the Membership plug-in, but it's still not working.

Please help... I haven't changed anything else and my site was running perfectly before I installed your plug-ins.

  • Michelle Shull

    Sure thing, Membership is a little tricky to get up and running. It's pretty robust, and there are a lot of details to cover.

    Once you reinstall, go right to the Membership settings and add both a new subscription level, and a new access level, in addition to any defaults, and give it full access to all parts of your site. As long as you're logged into your admin account, or *an* admin account, you should be fine.

    Don't log out to test other roles until you've tested the front end to make sure you can see it all.

    If you're still getting 500 errors, you might have an insufficient memory issue going on. That's not uncommon, and it's not terribly hard to fix. But before we get that far, let me know how the reinstall goes.

  • Sarah

    OK, I am reinstalling on a second domain, to run some tests.

    I created a new access level named Visitors, and put all of my website content in the Positive Rules section.

    I also created a new subscription called Visitors, and set it to not charge and be available infinitely. I added the Visitors content to that subscription level.

    However, my website is still showing up at "protected content."

    Can you help me identify what other steps I need to take to correctly set up my regular website content?

    Thank you,

    Sarah

  • Tyler Postle

    Hi Sarah,

    My apologies for the delay here! I would be more than happy to take a look at this right now for you so we can get this resolved ASAP :slight_smile: I will be online for the next 4 hours or so and will keep an eye on this thread for your reply.

    What settings were you working on before the home page slider started acting all weird? Can you enable support access then I can take a closer look at your settings, that will speed up the process a bit here.

    What sort of setup are you looking to have with Membership? I can help you get that all setup as well.

    I look forward to hearing back from you Sarah!

    Cheers,
    Tyler

  • Tyler Postle

    Hey Sarah,

    Thanks for getting back to me :slight_smile: Eliott kindly assigned your email to me so we can work together here and get all your Membership questions answered.

    I took a look in your site and found the issue. Your visitor level. Since you have it set to "Positive" rules, it blocks everything that you aren't specifically selecting access too. Which in this case it is likely blocking images. I made a "Guest" access level because I didn't want want to change your visitor set up. I set the guest with 'negative' rules and set it as the stranger access level.

    Then I flushed your cache. Make sure you flush the cache after any changes - because you are using a temporary domain it is being heavily cached to reduce server load.

    You can see now that your slider works as expected :slight_smile:

    So, either change your visitor level to negative rules and select what you DON'T want your visitors to see, or delete that level and edit the Guest one I made.

    Also, I changed your "Default Membership on sign up" option in your general settings to "None" - you had this set as your paid membership, you don't want this to be set for a paid membership because otherwise it will automatically set that subscription plan to the user whether they pay or not. You want them to select the membership and pay for it during sign up :slight_smile: I'm assuming?

    Hope this helps! Let me know if you have any further questions Sarah.

    All the best,
    Tyler

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.