membership plugin

I created different levels... including a free level for regular site visitors.
I also created a couple test members and assigned them to different member levels.
When I log in as a test member nothing at the site will load at all... I get a 404 error page. If I log out then the site loads fine... or if I log in as admin the site loads fine.
Same for free level... site loads fine. but for any of the other levels, site will not load at all. Please advise.
thanks Todd

  • Paul Barthmaier
    • Code Wrangler

    Hi there and welcome to the WPMU DEV Community for WordPress Support!

    The first thing I would do is to reset my permalinks for the site. You can also check the database table in the Advanced section of the plugin You can get there by appending this string:

    /wp-admin/admin.php?page=membershipoptions&tab=advanced

    to your domain. Hope this helps! Let us know how it goes.

    Cheers,
    Paul

    Plugin Trouble? Follow the chart: http://marker.to/K0G5yg

  • hishills
    • New Recruit

    hi Paul,
    tried your suggestions but no changes,
    When I am logged into the admin area there is a link at the top right that says:
    View site as... then it has a list of all my membership levels.
    If I click on any of those five different levels... except free... then go to View Site
    It tries to load and eventually comes to an error page.
    If I view site as a free member then I can view site fine.
    As far as I can see I have set up the levels almost identical. Only difference I can
    see is that the free member has less access so it is very odd that the free member can see the site and the other levels cannot.
    Todd

  • mort3n
    • The Crimson Coder

    Hi Todd,

    Is the free level restricted according to the settings?

    Are the test accounts shown as active in Membership->All members?

    Have you set the free level in
    Membership->Options->General tab->Stranger settings?

    Do you have a Protected content page in
    Membership->Options->Membership pages->Protected content page?

    Perhaps double check the logic of the Access level settings positive vs. negative rules.

    Cheers
    Mort3n

  • hishills
    • New Recruit

    Yes all the test accounts are active...
    Free level is set to the Free access level I created
    Protected content page... just using the default one created.

    Logic of all the access levels is positive only... I checked off the pages that I wanted that level to have access too.

    Two memberships... three if you count the free. Gold, Platinum.

    Gold - Five payments, one each month, access more material each month and access to everything after five monthly payments.
    Platinum - One payment and access to everything immediately forever.

    It just blows my mind that a stranger has more access then a member that is logged in. Apparently I have missed something... I don't have members area set up yet because when a member logs in the site will not even load.

    If you could just log in and take a peek at what I have done. This is my first time using this script... perhaps I have something wrong but I can keep staring at this for weeks and it will not start working.

    http://learn-forex.org/wp-admin
    login: kingweb
    pass: juL8765

    thanks for the help
    Todd

  • Paul Barthmaier
    • Code Wrangler

    Hi Todd,

    Another suggestion would be to check out the setup videos that one of our members did a while back to see if you missed anything along the way.

    https://premium.wpmudev.org/forums/topic/video-tutorial-how-to-set-up-a-membership-site#post-247873

    I think it's useful to hear someone talking you through the set up. There might be a helpful hint in there that makes all the difference for you!

    Cheers,
    Paul

    Want to change Q&A background color? Ask Patrick!

  • mort3n
    • The Crimson Coder

    Hi hishills,

    I think I may have figured it out :slight_smile:

    According to the plugin manual
    https://premium.wpmudev.org/wp-content/uploads/2010/05/Membership-Documentation-SJC.pdf
    URL Groups are used to specify URLs that should be protected.

    You have specified a URL Group for each Access level.

    In each Access level you use positive rules. You have added the URL Groups box and checked the URL Group corresponding to the Access level.

    Thus, you specify a URL Group that should be protected and then specify that this URL Group should be accessible.

    I tried removing the positive rule for the Month One Access level, went to the front and changed view to Month One. The endless loop is not encountered.

    Try it out.

    Cheers
    Mort3n

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.