Membership plugin, blank page

Hi,
Multisite 3.1.1 + Membership plugin, no BuddyPress.
When a new user signs he can enter a username, email address and password, but he does not receive an email verification and is not subscription form. The page appears as blank.

Membership is network activated
Membership is enabled
Categories are set
Subscription plans are activated and public.
I'm not sure what I am doing wrong.

Here is the error log:

Error log:
/home2/bizzable/public_html/stiitch/wp-admin/error_log:
[11-Apr-2011 21:55:07] WordPress database error Table 'bizzable_wrd2.wp_reports_user_activity' doesn't exist for query INSERT INTO wp_reports_user_activity (user_ID, location, date_time) VALUES ( '1', 'stiitch.net/wp-admin/admin.php?page=membershipsubs&action=delete&sub_id=4&_wpnonce=157ab96adb', '2011-04-11 21:55:07' ) made by include, do_action, call_user_func_array, Activity_Reports->user_activity
[11-Apr-2011 21:55:09] WordPress database error Table 'bizzable_wrd2.wp_reports_user_activity' doesn't exist for query INSERT INTO wp_reports_user_activity (user_ID, location, date_time) VALUES ( '1', 'stiitch.net/wp-admin/admin.php?page=membershipsubs&msg=2', '2011-04-11 21:55:09' ) made by include, do_action, call_user_func_array, Activity_Reports->user_activity
[11-Apr-2011 21:55:15] WordPress database error Table 'bizzable_wrd2.wp_reports_user_activity' doesn't exist for query INSERT INTO wp_reports_user_activity (user_ID, location, date_time) VALUES ( '1', 'stiitch.net/wp-admin/admin.php?page=membershipsubs&action=delete&sub_id=6&_wpnonce=dd6c8e697b', '2011-04-11 21:55:15' ) made by include, do_action, call_user_func_array, Activity_Reports->user_activity

I deactivated the user activity plugin.