membership plugin compatibility with wordpress 3.6 and new version of buddypress

Does the membership plugin work fine with the latest version of buddypress? Wordpress?

Corn