Membership Plugin creating membership pages through settings results in 404 errors for all pages.

Membership Plugin creating membership pages through settings results in 404 errors for all pages.

I currently have the permalink structure of “Pos Name”

This happes when the plugin generates any of the following pages




Your Subscription

Please advise.


PS. I had a friend fix this once, it had something to do with .htaccess file.

  • Paul Barthmaier
    • Code Wrangler

    Hi there and welcome to the WPMUdev Support Forums!

    First thing to check here is resetting your permalinks. It could be that htaccess will come into play, but if you haven’t made any changes to that file and you aren’t running multisite, it shouldn’t. Start with setting the Post Name as the permalink type and let us know what happens.



  • drewshane12
    • WPMU DEV Initiate

    Changes have been made to the .htacces file to fix this issue.

    I just deleted my .htaccess file and re-saved my sites permalink structure to “Postname”.

    Here is what my .htaccess looks like now.

    # BEGIN WordPress

    <IfModule mod_rewrite.c>

    RewriteEngine On

    RewriteBase /

    RewriteRule ^index.php$ – [L]

    RewriteCond %{REQUEST_FILENAME} !-f

    RewriteCond %{REQUEST_FILENAME} !-d

    RewriteRule . /index.php [L]


    # END WordPress

    Now what?

  • drewshane12
    • WPMU DEV Initiate

    Could you possibly take a look at my site?

    I can provide you a login for the site.

    What I notice is that when I am using the Permalink structure “Postname” and I save any settings in the Membership options it results in 404’s across my entire site on the front end.

    I have tried reseting my structure by deleting the .htaccess file and saving to default then to postname but still no success.

  • Paul Barthmaier
    • Code Wrangler

    Hey there,

    We’re getting closer. Seems like something needs to precede the post name. Not sure why WP is wanting that. And it doesn’t look like it’s theme or plugin related, so I’ll have to give this a think. Can you post the stuff from wp-config, from debug to happy blogging?

    define( 'WP_DEBUG', false );


    /* That's all, stop editing! Happy blogging. */



  • drewshane12
    • WPMU DEV Initiate

    Sure! No Prob! Thanks for the help, you guy’s have great support!

    It appears I have nothing located in that section of my config file. Here is what I have.


    * For developers: WordPress debugging mode.


    * Change this to true to enable the display of notices during development.

    * It is strongly recommended that plugin and theme developers use WP_DEBUG

    * in their development environments.


    define(‘WP_DEBUG’, false);

    /* That’s all, stop editing! Happy blogging. */

    /** Absolute path to the WordPress directory. */

    if ( !defined(‘ABSPATH’:wink: )

    define(‘ABSPATH’, dirname(__FILE__) . ‘/’:wink:;

    /** Sets up WordPress vars and included files. */

    require_once(ABSPATH . ‘wp-settings.php’:wink:;

  • Paul Barthmaier
    • Code Wrangler

    Ok, so as far as I can tell we’ve ruled everything out as far as WordPress goes. I’ll have someone else over here take a look and see if I missed something, but if not, that means it’s likely your host. You might have to triple check with them that mod_rewrite is enabled and if they swear it is, then you would tell them that your htaccess isn’t being read. You might want to consult what Andrea Rennick has to say here:

  • Tom Eagles
    • Syntax Hero

    Hiya, just going through some of the older threads here.

    As it’s been a little while since we last heard from you I thought I’d check in to see how you’re going?

    If you’re still looking for some further assistance with this thread then please feel free to reopen the thread or of course for any new and related issues you are most welcome to open a new thread.



Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.