Membership plugin doesnt allow members access

Hi,

I'm just opening this support so I don't hijack someone elses thread

I am using the free membership module, and when user clicks to activate it, they still don't have access to the pages they are supposed to, more importantly they can't access messages, their profile or anything. I have gone over it several times and given the right access, set it up in options to add user to membership level automatically too.

test1: I have also tried to add subscription manually but it doesn't work

test 2: I can add membership level manually

test 3: newly registered user is not added to any membership level or subscription automatically
The only member that can access his profile and other locked pages is admin

  • DavidM
    • DEV MAN’s Mascot

    Hi edwardhadome,

    From the other thread it seemed as if the subscriptions were working, is that correct? So you can manually add subscriptions to a member with no trouble?

    And it seems the issue now comes down to users not being able to access particular pages? As we didn't cover it in the other thread or here, are you using Membership alongside BuddyPress?

    Thanks for your patience while we get this sorted!
    David

  • ed
    • Design Lord, Child of Thor

    HI, thanks

    Yes subscriptions are now working. I reinstalled the membership plugin, updated the studio theme to the latest and subscriptions seem to work. However the main issue now is that users apart from admin cannot see their profile, or read messages, or anything under the my account tab.

    yes please, we are using buddypress with the membership plugin

    so
    1: Can you add users manaually? Right now I am using only free membership and they add automatically now, so its fine

    2; Can they access the private page when they becoem members? YES, it works as supposed to now

    3: Can they access their profile and messages or account pages? NO, this seems to be blocked, and users are redirected to the page I set for users to see if they are not susbscribed. and when they click to subscribe, it says they are already subscribed

    Maybe I should have posted this on other thread. :slight_smile: thanks

  • Mason
    • DEV MAN’s Sidekick

    Hiya edwardhadome,

    Have you been able to get the information together David's asking about?

    The membership plugin allows for loads of customization, but that means tracking down an issue can take a bit longer than usual. Still, we'd love to assist if we can. I'm hoping this has been resolved and am marking it as such. If not and you'd like to continue receiving support, just click the 're-open' button and let us know how things are going.

    We'll gladly follow up from there.

    Thanks!

  • misp
    • New Recruit

    I am having the same problem, all works well except for profile access (of maximum importance). I dont plan to charge for access and im having already traffic so unles there is a fix imediatly i iwll have to turn it off. Any news on this? thanks in advance.

    Mirela

    Ps.: this is exactly my problem:

    3: Can they access their profile and messages or account pages? NO, this seems to be blocked, and users are redirected to the page I set for users to see if they are not susbscribed. and when they click to subscribe, it says they are already subscribed

  • Barry
    • DEV MAN’s Mascot

    Can they access their profile and messages or account pages? NO, this seems to be blocked, and users are redirected to the page I set for users to see if they are not susbscribed. and when they click to subscribe, it says they are already subscribed

    MISP - can you give us some details of your setup so we can try to work out what's happening? There has been a couple of Membership plugin updates since this thread started so if you can let us know the version of that you are running as well that would be great.

  • misp
    • New Recruit

    Hello Barry, thanks for the reply. I just installed the wpmudev updates and saw there is an update on the membership, ill install it and make the tests then i get back to you. I unninstalled since my last post so ill give it another try this week and let you know the outcome. ty.

    Mirela

  • DavidM
    • DEV MAN’s Mascot

    Hi Mirela,

    There's been a nice beta release in the following thread that provides compatibility with WP 3.2 (the latest major update). You'll need to update using that version for now if you're using WP 3.2.
    https://premium.wpmudev.org/forums/topic/membership-version-21-beta-2

    @edwardhadome, let us know if you're still experiencing difficulty with that with the more recent versions and we'll take a look with ya!

    Thanks,
    David

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.