membership plugin doesnt work

I just bought the membership plugin through the app sumo deal – when i attempt to activate the plugin i get the following error… Please Advise.

Fatal error: Call to undefined method stdClass::set_help_sidebar() in /nfs/c04/h02/mnt/64061/domains/ on line 73

  • ThePath
    • The Bug Hunter

    Hi stephanattar, thanks for being a member and for using the forum.

    Normally when these “undefined” errors pop up its when somethings gone wrong with the install. Can I ask how you installed Membership? If it was ftp its well worth uploading all the files again and retrying the install.

    You could also delete all the files and attempt the install using the WP plugin installer.

    Hope you get it sorted but if the above doesnt work then please come back and let us know and we will help further.


  • stephanattar
    • New Recruit

    i re-downloaded it twice and re-installed it 4 times via both FTP and the WP plug in installer by uploading the zipped file (i thought maybe unzipping the file on a mac might have made it buggy)… but i’m still getting the same error :slight_frown:

    Please Advise.

  • Mason
    • DEV MAN’s Sidekick

    Hiya @stephanattar,

    I’m totally stumped. What version of PHP do you have running on the server?

    If you’re not sure you can check by creating a phpinfo.php. This is simple and easy. With a simple text editor (such as Notepad), create a new “phpinfo.php” file containing this code, and only this:

    <?php phpinfo(); ?>

    Upload this page to your server, and call it with your Internet browser. Now a page should be displayed telling you the PHP version installed on your server and many more detail information.

    I’m gonna ask for a few other folks if they have any ideas as well. Thanks!

  • Timothy
    • Chief Pigeon

    Unpacking on Mac won’t make a difference here. The Archive Utility which comes with Mac handles Zips just fine. :slight_smile:

    I’m also a Mac user.

    The Method (class and function) stdClass::set_help_sidebar is a WordPress one (well stdClass is PHP but the latter is WP), so it should be available within your install and has been in WP since around 3.3. It’s for the contextual help in WordPress.

    I don’t get this error myself.

    I’d also try replace all the WP files to ensure nothing was missing there. Just be sure to keep your wp-config.php and htaccess.

    Let use know how that goes.

  • ThePath
    • The Bug Hunter

    Soorry stephanattar,

    I was away being a country lad. Erm to be honest I dont think I can add anything else to this thread. Apart from does it happen when trying to install any other plugins?

    Do you have any other plugins running? Have you tried disabling them all and then retrying the Membership install.

    Ive never had this error when installing membership.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.